Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168614 - java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle
java.util.MissingResourceException: No such bundle org.netbeans.modules.debug...
Status: VERIFIED WONTFIX
Product: javafx
Classification: Unclassified
Component: Debugger
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Adam Sotona
issues@javafx
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 166849 184009 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 14:07 UTC by Jaroslav Pospisil
Modified: 2010-04-13 22:05 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.42 KB, text/plain)
2009-07-15 14:07 UTC, Jaroslav Pospisil
Details
stacktrace (1.42 KB, text/plain)
2009-07-15 14:08 UTC, Filip Zamboj
Details
stacktrace (4.82 KB, text/plain)
2009-07-15 15:07 UTC, Andrei Chistiakov
Details
stacktrace (1.33 KB, text/plain)
2009-07-16 12:12 UTC, Ivan Sidorkin
Details
stacktrace (1.42 KB, text/plain)
2009-07-17 09:33 UTC, matusdekanek
Details
stacktrace (1.42 KB, text/plain)
2009-07-20 09:05 UTC, pribyl
Details
stacktrace (3.08 KB, text/plain)
2009-07-20 10:50 UTC, Filip Zamboj
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Pospisil 2009-07-15 14:07:38 UTC
This issue was originally marked as duplicate of issue 166849, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE 6.7.1 RC (Build 200907150227)
VM: Java HotSpot(TM) Client VM, 14.0-b15, Java(TM) SE Runtime Environment, 1.6.0_14-b07
OS: Windows Vista, 6.0, x86

User Comments:
jpospisil: starting freshly installed IDE with custom (clean) userdir



Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 1 Jaroslav Pospisil 2009-07-15 14:07:50 UTC
Created attachment 84778 [details]
stacktrace
Comment 2 Filip Zamboj 2009-07-15 14:08:38 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907150227)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-13-generic, amd64

User Comments: 
run 671 with fresh userdir

Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 3 Filip Zamboj 2009-07-15 14:08:51 UTC
Created attachment 84779 [details]
stacktrace
Comment 4 Filip Zamboj 2009-07-15 14:18:40 UTC
I guess this may be showstopper for 6.7.1, it's kinda unpleasant to see an exception right after start ... 
Comment 5 Marian Mirilovic 2009-07-15 14:33:17 UTC
I can't reproduce it ... using All IDE from zip.
Comment 6 Jaroslav Pospisil 2009-07-15 14:37:41 UTC
I have full IDE from installer, JDK 1.6.0_14, Win Vista
Comment 7 Filip Zamboj 2009-07-15 14:46:18 UTC
it's reproducible if you install from netbeans-6.7.1rc-linux.sh so it looks like installer problem 

after talk with jpospisil I increase to P1 as a showstopper for 6.7.1.
Comment 8 Andrei Chistiakov 2009-07-15 15:07:22 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907150227)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 9 Andrei Chistiakov 2009-07-15 15:07:40 UTC
Created attachment 84785 [details]
stacktrace
Comment 10 Marian Mirilovic 2009-07-15 16:52:52 UTC
Definitely stopper for NB 6.7.1 - please investigate and fix ASAP. Thanks in advance.
Comment 11 Daniel Prusa 2009-07-15 22:16:38 UTC
Issue 166849 has been resolved, but only as worksforme, it does not seem that there were any related fixes committed.
The stack trace is still the same, so I guess this is still the same issue.
Comment 12 Marian Mirilovic 2009-07-16 08:08:09 UTC
*** Issue 166849 has been marked as a duplicate of this issue. ***
Comment 13 Ivan Sidorkin 2009-07-16 12:12:46 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907150227)
VM: Java HotSpot(TM) Client VM, 1.5.0_19-b02, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_19-b02
OS: SunOS, 5.11, x86

User Comments: 
started NB 

Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 14 Ivan Sidorkin 2009-07-16 12:12:56 UTC
Created attachment 84824 [details]
stacktrace
Comment 15 Exceptions Reporter 2009-07-16 12:13:11 UTC
This issue already has 12 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=153733
Comment 16 Tomas Pavek 2009-07-16 18:26:09 UTC
Actually caused by JavaFX debugger.

org/netbeans/modules/debugger/javafx/resources/mf-layer.xml references "org.netbeans.modules.debugger.jpda.ui.Bundle" as
localizing bundle for a menu. The bundle file is from JPDA debugger, but the JavaFX module does not depend on JPDA
debugger module. So if JavaFX debugger is enabled but JPDA debugger is not, the bundle file is missing.
Comment 17 matusdekanek 2009-07-17 09:33:23 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907162301)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.28-13-generic, i386

User Comments: 
started IDE

Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 18 matusdekanek 2009-07-17 09:33:29 UTC
Created attachment 84877 [details]
stacktrace
Comment 19 Exceptions Reporter 2009-07-17 09:33:34 UTC
This issue already has 14 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=153733
Comment 20 Marian Mirilovic 2009-07-17 14:01:57 UTC
It will be fixed in NB 6.7.1 - but not as a part of Patch 1
Comment 21 Petr Suchomel 2009-07-17 15:19:55 UTC
Added dependence to kit CS cd01793818c3
Comment 22 pribyl 2009-07-20 09:05:15 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907162301)
VM: Java HotSpot(TM) Client VM, 16.0-b03, Java(TM) SE Runtime Environment, 1.7.0-ea-b59
OS: Windows XP, 5.1, x86

User Comments: 
I just launched the IDE (with clean userdir)

Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 23 pribyl 2009-07-20 09:05:26 UTC
Created attachment 84920 [details]
stacktrace
Comment 24 Filip Zamboj 2009-07-20 10:50:14 UTC
Build: NetBeans IDE 6.7.1 RC (Build 200907162301)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-13-generic, amd64

User Comments: 
started netbeans wuth clean userdir

Stacktrace: 
java.util.MissingResourceException: No such bundle org.netbeans.modules.debugger.jpda.ui.Bundle<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:440)<br/>
        at org.openide.util.NbBundle.getBundle(NbBundle.java:373)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:201)<br/>
        at org.netbeans.core.startup.layers.SystemFileSystem.annotateName(SystemFileSystem.java:228)<br/>
        at org.openide.loaders.DataNode.getDisplayName(DataNode.java:190)<br/>
        at org.openide.awt.MenuBar$LazyMenu.updateProps(MenuBar.java:514)<br/>
Comment 25 Filip Zamboj 2009-07-20 10:50:19 UTC
Created attachment 84925 [details]
stacktrace
Comment 26 Filip Zamboj 2009-07-20 12:17:57 UTC
i didn't reproduce this issue in 
Product Version: NetBeans IDE 6.7.1 (Build 200907192301)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02
Comment 27 Marian Mirilovic 2009-07-20 13:32:10 UTC
Checked javafx repository ... looks like it's fixed :
http://hg.netbeans.org/javafx/rev/cd01793818c3
... so do not forget to close an issue once you fix it, please.
Comment 28 Martin Entlicher 2009-07-21 09:55:07 UTC
Just FYI: This fix looks very strange. Is not Java FX debugger a copy of JPDA debugger? Then does the copy have to
depend on it's original? Doesn't it reference a wrong bundle?
Comment 29 Jaroslav Tulach 2009-07-22 16:33:28 UTC
I managed to simulate the problem locally. Basically the exception is thrown due to following folder:


    <!-- Main menu -->
     <folder name="Menu">
        <folder name="RunProject">
            <folder name="Stack">
                <attr name="SystemFileSystem.localizingBundle" 
stringvalue="org.netbeans.modules.debugger.jpda.ui.Bundle"/>
                <attr name="SystemFileSystem.icon" 
urlvalue="nbresloc:/org/netbeans/modules/debugger/resources/actions/Folder.gif"/>

This is a layer defined in org.netbeans.modules.debugger.jpda.ui, but this module is not in the list of enabled ones:

        org.netbeans.api.debugger/1 [1.17.1 200907162301]
        org.netbeans.api.debugger.jpda/2 [2.19.1 200907162301]
        org.netbeans.modules.debugger.jpda.ant [1.11.1 200907162301]
        org.netbeans.spi.debugger.ui/1 [2.16.2 200907162301]
        org.netbeans.modules.debugger.jpda.projects [1.5.2 200907162301]
        org.netbeans.modules.debugger.jpda/2 [1.23.2 200907162301]
        org.netbeans.modules.ant.debugger/1 [1.11.1.2 200907162301]
        org.netbeans.modules.web.client.javascript.debugger.ant [0.7.1 200907162301]

All I had to do was to install 
/net/smetiste/space/builds/netbeans/6.7.1/rc/2009-07-16_23-01-10/bundles/netbeans-6.7.1rc-linux.sh
and patch java.kit with following patch:

--- a/java.kit/nbproject/project.xml    Wed Jul 22 15:59:21 2009 +0200
+++ b/java.kit/nbproject/project.xml    Wed Jul 22 17:31:33 2009 +0200
@@ -35,6 +35,19 @@
                     </run-dependency>
                 </dependency>
                 <dependency>
+                    <code-name-base>org.netbeans.modules.debugger.jpda</code-name-base>
+                    <run-dependency>
+                        <release-version>2</release-version>
+                        <specification-version>1.23.2</specification-version>
+                    </run-dependency>
+                </dependency>
+                <dependency>
+                    <code-name-base>org.netbeans.modules.debugger.jpda.projects</code-name-base>
+                    <run-dependency>
+                        <specification-version>1.5.2</specification-version>
+                    </run-dependency>
+                </dependency>
+                <dependency>
                     <code-name-base>org.netbeans.modules.i18n</code-name-base>
                     <run-dependency>
                         <release-version>1</release-version>
Comment 30 Martin Entlicher 2009-07-22 16:46:32 UTC
IMHO: It's mad to add a module dependency just because of some resource bundle.

Is the *reference* to the resource bundle correct? Should not it reference a resource bundle from JavaFX debugger???
Comment 31 Jesse Glick 2009-07-22 16:48:14 UTC
So what actually is the issue, and why is this assigned to module system? If you want
org.netbeans.modules.debugger.jpda.ui enabled, include it in the deps of java.kit.
Comment 32 Jaroslav Tulach 2009-07-22 17:24:06 UTC
Opps, my mistake. I used "Open Layer(s)" and got two modules defining the file (cnd and jpda). However I have not 
realized that the javafx is in another repository and was not shown to me. The only thing that makes me believe this 
might be fixed in platform/module system is following hint:

diff -r 9b11bbd93c65 core.startup/src/org/netbeans/core/startup/layers/SystemFileSystem.java
--- a/core.startup/src/org/netbeans/core/startup/layers/SystemFileSystem.java   Wed Jul 22 15:59:21 2009 +0200
+++ b/core.startup/src/org/netbeans/core/startup/layers/SystemFileSystem.java   Wed Jul 22 18:22:42 2009 +0200
@@ -51,6 +51,7 @@
 import java.io.ObjectStreamException;
 import java.io.Serializable;
 import java.net.URL;
+import java.util.Arrays;
 import java.util.HashSet;
 import java.util.MissingResourceException;
 import java.util.ResourceBundle;
@@ -204,9 +205,8 @@
                     // ignore--normal
                     }
             } catch (MissingResourceException ex) {
-                ModuleLayeredFileSystem.err.log(
-                        Level.WARNING,
-                        "Computing display name for " + fo, ex); // NOI18N
+                Exceptions.attachMessage(ex, "Computing display name for " + fo + " defined by " + 
Arrays.toString((Object[])fo.getAttribute("layers")));
+                ModuleLayeredFileSystem.err.log(Level.WARNING, null, ex);
             // ignore
             }
         }

Definitely no this hint in platform is not candidate for 6.7.1. I am sorry if I messed up something with priorities.
Comment 33 Jaroslav Tulach 2009-07-22 17:25:34 UTC
Definitely no hint in platform like this shall be candidate for 6.7.1. I am sorry if I messed up something.
Comment 34 Jesse Glick 2009-07-22 18:15:55 UTC
I can put in diagnostics of that kind (edited for style) in core-main #985418c112d9, but I guess the actual problem is
unfixed and somehow in javafx. The changeset javafx #cd01793818c3 looks strange to me; seems like the fix should be to
define the folder name in the same module, not to introduce an artificial module dependency.
Comment 35 Tomas Pavek 2009-07-22 18:39:17 UTC
The fix is probably ok for 6.7.1. The problem does not appear anyway since JavaFX is properly included in ergonomics. 
Since this code is not supposed to be used with 6.8 dev, and for 6.8 the JavaFX debugger will be completely rewritten 
(declaring direct dependencies on java debugger modules), there's probably nothing to do with this in JavaFX (add 
another fix to release67_fixes does not make sense). I suggest wontfix.
Comment 36 Quality Engineering 2009-07-23 17:48:44 UTC
Integrated into 'main-golden', will be available in build *200907231401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/985418c112d9
User: Jesse Glick <jglick@netbeans.org>
Log: Better diagnostics for #168614: missing bundle for SystemFileSystem.localizingBundle.
Comment 37 Adam Sotona 2009-08-04 16:34:19 UTC
I agree with WONTFIX as the added dependency workaround works for 6.7.1 and the debugger will be completelly new for 6.8
This issue was caused by copy/paste programing of the JavaFX debugger module long time ago and appears only with the new
all-bundle and ergonomics. All previous releases did not created a situation when org.netbeans.modules.debugger.jpda.ui
is not loaded and JavaFX debugger is.
Comment 38 Alexandr Scherbatiy 2009-09-29 10:17:24 UTC
The JavaFX debugger is rewritten.
Comment 39 Daniel Prusa 2010-04-13 22:05:33 UTC
*** Bug 184009 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo