Bug 168610 - Compilation job never ends
Compilation job never ends
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-15 13:41 UTC by Tomas Mysik
Modified: 2009-07-20 09:49 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (15.96 KB, text/plain)
2009-07-15 13:41 UTC, Tomas Mysik
Details
other one (33.67 KB, text/plain)
2009-07-15 14:27 UTC, rmatous
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2009-07-15 13:41:13 UTC
Attaching thread dump, navigator shows "Please wait..." for every PHP file (other files, e.g. XML, are OK).

Product Version: NetBeans IDE Dev (Build 090714)
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02
System: Linux version 2.6.28-13-generic running on amd64; UTF-8; cs_CZ (nb)
Comment 1 Tomas Mysik 2009-07-15 13:41:55 UTC
Created attachment 84774 [details]
thread dump
Comment 2 mslama 2009-07-15 14:01:17 UTC
*** Issue 161666 has been marked as a duplicate of this issue. ***
Comment 3 mslama 2009-07-15 14:01:53 UTC
*** Issue 161166 has been marked as a duplicate of this issue. ***
Comment 4 rmatous 2009-07-15 14:27:02 UTC
Created attachment 84782 [details]
other one
Comment 5 mslama 2009-07-15 14:38:57 UTC
Second thread dump is ok. Lock is hold by "Default RequestProcessor" daemon prio=1 tid=0x83c44210 nid=0x233a and this
thread is running. But in first thread dump I do not see any thread holding lock.
Comment 6 Jan Jancura 2009-07-15 15:33:44 UTC
TaskProcessor lock is private and safe.
This issue is caused by:
Reformatter.reformatLock ()
or
JavaSourceAccessor.lockJavaCompiler ()

-> java.source
Comment 7 Vitezslav Stejskal 2009-07-15 15:56:04 UTC
We will have a look...
Comment 8 Dusan Balek 2009-07-16 13:12:02 UTC
CreateTestsAction does not call reformat.unlock() in its reformat(...) method. Reassigning to PHP.
Comment 9 Tomas Mysik 2009-07-16 13:19:27 UTC
Agreed.
However, in such case issue #161666 and issue #161166 cannot be duplicates of this one, so reopening them...
Comment 10 Tomas Mysik 2009-07-16 13:22:06 UTC
> [...] cannot be duplicates of this one

because reformat to PHP was added a few days ago.
Comment 11 Tomas Mysik 2009-07-16 13:33:43 UTC
Fixed.
http://hg.netbeans.org/web-main/rev/8d16146a11b2
Comment 12 Quality Engineering 2009-07-20 09:49:21 UTC
Integrated into 'main-golden', will be available in build *200907200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/8d16146a11b2
User: Tomas Mysik <tmysik@netbeans.org>
Log: #168610: Compilation job never ends


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo