Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168536 - Invoking Open Project took 45,800 ms.
Invoking Open Project took 45,800 ms.
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: Settings
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT perf-profileme
:
: 168056 (view as bug list)
Depends on: 161201
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-14 11:37 UTC by Jindrich Sedek
Modified: 2009-09-03 21:44 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
nps snapshot (84.80 KB, bin/nps)
2009-07-14 11:37 UTC, Jindrich Sedek
Details
nps snapshot (25.39 KB, bin/nps)
2009-07-21 12:57 UTC, Martin Schovanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jindrich Sedek 2009-07-14 11:37:25 UTC
Build: NetBeans IDE Dev (Build 200907130200)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Linux, 2.6.27.25-170.2.72.fc10.x86_64, amd64

User Comments:
jsedek: I had opened pom maven project and I was opening web project embedded in the original one


Maximal alredy reported slowness was 45800 ms, average is 45800
Comment 1 Jindrich Sedek 2009-07-14 11:37:30 UTC
Created attachment 84697 [details]
nps snapshot
Comment 2 Jaroslav Tulach 2009-07-14 12:49:46 UTC
*** Issue 168056 has been marked as a duplicate of this issue. ***
Comment 4 Vitezslav Stejskal 2009-07-14 15:27:45 UTC
AFAIR I was making some fixes around this area. There is a huge number of events fired from filesystems that all make
MimeLookup to recalculate its contents. These events are fired from an AtomicAction, so they really come in one huge
bundle. Unfortunately it's not possible to recognize this from the API client's side, ie. one does not know that there
is the whole lump of events coming and so can't do the refresh only once. Instead each event is delivered separately and
triggers the refresh again and again. A possible solution could be to use a sliding task (an async task) that is
(re)scheduled when an event arrives and that does the refresh. The drawback is that its asynchronous...
Comment 5 Vitezslav Stejskal 2009-07-16 17:24:11 UTC
http://hg.netbeans.org/jet-main/rev/df4e2c88c39d
Comment 6 Quality Engineering 2009-07-20 09:49:29 UTC
Integrated into 'main-golden', will be available in build *200907200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/df4e2c88c39d
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #168536: hopefully better algorithm for coalescing filesystem events
Comment 7 Martin Schovanek 2009-07-21 12:57:13 UTC
Build: NetBeans IDE Dev (Build 200907210201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02-83, Java(TM) SE Runtime Environment, 1.6.0_13-b03-211
OS: Mac OS X, 10.5.7, x86_64

User Comments: 

Maximal alredy reported slowness was 45800 ms, average is 12643
Comment 8 Martin Schovanek 2009-07-21 12:57:17 UTC
Created attachment 84999 [details]
nps snapshot
Comment 9 Jindrich Sedek 2009-07-27 10:34:59 UTC
verified.
NetBeans IDE Dev (Build 200907270201)
Comment 10 Vitezslav Stejskal 2009-09-03 21:44:44 UTC
Please also see the latest comments in issue #161201.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo