Bug 168457 - Deadlock while attaching the debugger to a remote app
Deadlock while attaching the debugger to a remote app
Status: RESOLVED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Daniel Prusa
issues@debugger
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-13 07:45 UTC by Marian Petras
Modified: 2009-07-14 06:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
full thread-dump (from jstack) (21.38 KB, text/plain)
2009-07-13 07:45 UTC, Marian Petras
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Petras 2009-07-13 07:45:16 UTC
The IDE got locked while attaching to a second instance of NetBeans.

Apparently, the deadlock was caused by scheduling a task using EventQueue.invokeAndWait(...). The task cannot be
finished until the thread that scheduled it relieves a lock. But the lock cannot be relieved until the scheduled task
finishes.

See the attached thread-dump.

--
NetBeans IDE 6.8 dev. build 090712 (#ba97e19b3b18)
JDK 6u14, 64-bit, server VM
Linux (Debian Lenny), 64-bit, Intel CPU
Comment 1 Marian Petras 2009-07-13 07:45:49 UTC
Created attachment 84638 [details]
full thread-dump (from jstack)
Comment 2 Daniel Prusa 2009-07-13 14:34:29 UTC
Fixed.
http://hg.netbeans.org/main/rev/7a11d0703c6a
Comment 3 Quality Engineering 2009-07-14 06:23:49 UTC
Integrated into 'main-golden', will be available in build *200907140201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7a11d0703c6a
User: Daniel Prusa <dprusa@netbeans.org>
Log: #168457: Deadlock while attaching the debugger to a remote app


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo