Bug 16840 - getTables() not returning all tables for MS SQL via Avenir
getTables() not returning all tables for MS SQL via Avenir
Status: CLOSED INVALID
Product: db
Classification: Unclassified
Component: Code
-FFJ-
PC Linux
: P2 (vote)
: 3.x
Assigned To: issues@db
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 23:37 UTC by Larry D. Wilson
Modified: 2003-06-30 17:17 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Larry D. Wilson 2001-10-22 23:37:56 UTC
Using JDBC driver from www.atinav.com (CaveCEXAPI25C.jar) to connect to remote
MS SQL Server 2000 instance.

The "Tables" folder in the Explorer only displays 2 of the tables. Using
Explorer, Execute command, I can query successully any of the missing tables.

This behavior is also apparent on the Views and Procedures folders (only
displays a subset of the schema)
Using JDK 1.4 beta2, RedHat 7.1 Prof, Avenir 2.5, and Forte4J 3.0
Comment 1 Radko Najman 2001-10-24 13:09:32 UTC
The problem is caused by Avenir's DatabaseMetaData.getSchemas() method implementation. The method doesn't 
return all available schemas so you cannot choose the rigth schema and that's why you don't see your 
tables. 
Comment 2 Martin Schovanek 2003-03-12 14:14:39 UTC
VERIFIED
Comment 3 Quality Engineering 2003-06-30 17:17:44 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo