Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168397 - GUI Builder editor should focus at editor after close Find feature instead [Source][Design] buttons
GUI Builder editor should focus at editor after close Find feature instead [S...
Status: RESOLVED WORKSFORME
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
: NETFIX
: 169682 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 12:55 UTC by Michel Graciano
Modified: 2013-01-08 12:52 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (1.88 KB, patch)
2009-07-10 19:23 UTC, Michel Graciano
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2009-07-10 12:55:52 UTC
[ BUILD # : 200906241340 ]
[ JDK VERSION : 1.6.* ]

As described by jrechtacek at issue #168108, the focus after cancel
Find feature goes to [Source][Design] buttons instead to the editor.
I wish to try to fix it by NetFIX program if you don't mind.
Comment 1 Michel Graciano 2009-07-10 19:22:43 UTC
In the truth it is an issue at core/multiview project. The attached patch I fixed it and I can't see any regression. I
tested it against Matisse and web.xml multview editors and even keyboard navigation with Ctrl+F10 still works as usual.
Probably the component and subcomponent should be updated.
Comment 2 Michel Graciano 2009-07-10 19:23:28 UTC
Created attachment 84612 [details]
Proposed patch
Comment 3 Antonin Nebuzelsky 2009-07-13 11:10:53 UTC
Jirko, review the proposed patch. Thanks.
Comment 4 Jiri Rechtacek 2009-07-13 14:07:24 UTC
Thanks for the patch a lot. It was integrated in http://hg.netbeans.org/core-main/rev/25cfbc799027.
Comment 5 Jiri Kovalsky 2009-07-13 15:07:11 UTC
Thanks a lot Jirko!
Comment 6 Michel Graciano 2009-07-13 15:17:33 UTC
Thanks guys. I will mark it as verified as soon as I get the build.

Regards
Comment 7 Quality Engineering 2009-07-14 06:22:38 UTC
Integrated into 'main-golden', will be available in build *200907140201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/25cfbc799027
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #168397: GUI Builder editor should focus at editor after close Find feature instead [Source][Design] buttons (applied hmichel's patch)
Comment 8 Michel Graciano 2009-07-15 14:55:33 UTC
v. 200907140201
Comment 9 Jiri Kovalsky 2009-07-15 16:00:56 UTC
Michel, this bug is NOT included in the 6.7.1. You verified it only in a trunk build, didn't you? Thanks!
Comment 10 Michel Graciano 2009-07-15 17:20:35 UTC
Sorry Jiri. I marked it with wrong status. I wished to mark with 67patch-candidate to the next patch if possible. My
mistake. Sorry again and thanks for quick fix. :(
I think there is any problem to mark with 67patch-candidate right? I know it is an minor fix and could be available in
the future.

Regards
Comment 11 Jiri Kovalsky 2009-07-15 17:50:19 UTC
Yes, that's correct. Adding the right keyword however the chances are small because 6.7.1 RC is available since today
[1] and we don't plan any 6.7.2 at the moment.

[1] http://bits.netbeans.org/netbeans/6.7.1/rc/2009-07-15_02-27-33/
Comment 12 mslama 2009-08-11 18:47:27 UTC
*** Issue 169682 has been marked as a duplicate of this issue. ***
Comment 13 David Strupl 2012-12-18 10:09:58 UTC
While examining 
http://netbeans.org/bugzilla/show_bug.cgi?id=202097
I have found out that the patch, especially the call to getEditorPane() is causing the slowness in cases when the editor has not been initialized yet. There is the gray rectangle with "please wait" but the call to getEditorPane from this patch blocks the AWT until the background initialisation is done.

I have reverted the patch as
http://hg.netbeans.org/jet-main/rev/8b5652742ad8
and I am reopening this report.

I am not sure whether the original symptoms of this report are still present. If they are another patch needs to be find to fix it.
Comment 14 Stanislav Aubrecht 2012-12-18 10:27:54 UTC
(In reply to comment #13)
> While examining 
> http://netbeans.org/bugzilla/show_bug.cgi?id=202097
> I have found out that the patch, especially the call to getEditorPane() is
> causing the slowness in cases when the editor has not been initialized yet.
> There is the gray rectangle with "please wait" but the call to getEditorPane
> from this patch blocks the AWT until the background initialisation is done.
> 
> I have reverted the patch as
> http://hg.netbeans.org/jet-main/rev/8b5652742ad8
> and I am reopening this report.

There's similar code here: http://netbeans.org/bugzilla/show_bug.cgi?id=168108
You may want to rollback that fix as well...
Comment 15 Michel Graciano 2012-12-18 17:36:33 UTC
Thanks David and sorry for the regression. I will evaluate both patches later.
Comment 16 Stanislav Aubrecht 2013-01-08 12:52:59 UTC
I can't reproduce in 

Product Version: NetBeans IDE Dev (Build 20130107-f7a62bf72db9)
Java: 1.6.0_23; Java HotSpot(TM) 64-Bit Server VM 19.0-b09
Runtime: Java(TM) SE Runtime Environment 1.6.0_23-b05
System: Windows 7 version 6.1 running on amd64; Cp1250; cs_CZ (nb)

Issue #168108 isn't reproducible either.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo