Bug 168380 - Not able to submit breakpoint : No executable location available
Not able to submit breakpoint : No executable location available
Status: CLOSED DUPLICATE of bug 115033
Product: debugger
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@debugger
issues@debugger
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-10 04:38 UTC by davidacampbell
Modified: 2010-05-06 08:02 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description davidacampbell 2009-07-10 04:38:41 UTC
Making this bug with reference to:
   http://forums.netbeans.org/post-41171.html

I am not the poster of that forum issue, but I see the problem regularly.

Basically when debugging an EJBs hosted in glassfish, there are large chunks of the source code for which I wrongly
cannot set a debugger breakpoint, even when the code is compiled with debugging enabled.

If I'm debugging, I can be single-stepping through the code and a single step takes me over the top of all this
non-breakpointable code further in the source file.  Obviously the single-step functionality can't set a breakpoint at
the next line either.
Comment 1 Martin Entlicher 2009-07-24 22:37:51 UTC
I believe that this is the same problem as described in issue #115033.
This should be fixed in NetBeans 6.8 dev and upcoming 6.7.1. The problem arises when different versions of the
application are deployed several times to the server.

*** This issue has been marked as a duplicate of 115033 ***
Comment 2 Marian Mirilovic 2010-05-06 08:02:23 UTC
verified duplicate


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo