Bug 16836 - OW hyperlinking fails on certain lines in a testcase
OW hyperlinking fails on certain lines in a testcase
Status: CLOSED FIXED
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
PC Linux
: P4 (vote)
: 6.x
Assigned To: akemr
ivan
:
: 18250 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-10-22 19:31 UTC by Jesse Glick
Modified: 2008-12-23 08:34 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2001-10-22 19:31:27 UTC
[dev oct 19] While output window hyperlinking normally works for me,
there are some weird circumstances where it does not. For example, run
the class
core/test/unit/src/org/netbeans/core/lookup/InstanceDataObjectModuleTest.java,
rev 1.1 (now deleted).

(I use this classpath to run it:
/space/src/nb_all/openide/test/unit/src:/space/src/nb_all/core/test/unit/src:/space/src/nb_all/openide/src:/space/src/nb_all/core/src:/space/src/nb_all/openide/netbeans/lib/openide.jar:/space/src/nb_all/core/netbeans/lib/core.jar:/space/src/nb_all/core/netbeans/lib/ext/crimson.jar:/space/src/nb_all/core/netbeans/lib/ext/jh.jar:/space/src/nb_all/core/netbeans/lib/ext/parser.jar:/space/src/nb_all/core/netbeans/lib/ext/regexp.jar:/space/src/nb_all/core/netbeans/lib/ext/terminalemulator.jar:/space/src/nb_all/core/netbeans/lib/ext/xerces.jar:/space/src/nb_all/xtest/lib/junit.jar:/space/src/nb_all/xtest/lib/junit-ext.jar)

It has one failing test,
testReloadDotInstanceSwitchesLookupByNewClass. This test prints a
stack trace when run:

There was 1 failure:
1)
testReloadDotInstanceSwitchesLookupByNewClass(org.netbeans.core.lookup.InstanceDataObjectModuleTest)junit.framework.AssertionFailedError:
Assignable to template class: c=test1.SomeAction a.class=test1.SomeAction
        at
org.netbeans.core.lookup.InstanceDataObjectModuleTest.existsSomeAction(InstanceDataObjectModuleTest.java:116)
        at
org.netbeans.core.lookup.InstanceDataObjectModuleTest.testReloadDotInstanceSwitchesLookupByNewClass(InstanceDataObjectModuleTest.java:173)
        at org.netbeans.junit.NbTestCase.run(NbTestCase.java:74)
        at
org.netbeans.core.lookup.InstanceDataObjectModuleTest.main(InstanceDataObjectModuleTest.java:45)

FAILURES!!!

The first stack trace line, in existsSomeAction(), is not hyperlinked.
(All relevant sources are mounted, incl. IDOMT.java, and the next line
from the same class is hyperlinked.) If the exact same output is
printed from an Ant script using <echo>, all lines are correctly
hyperlinked. So I think this has something to do with timing of the
output, perhaps with intermixing of stdout and stderr.
Comment 1 Jesse Glick 2001-11-13 15:39:10 UTC
Still easily reproducible, by the way; seems to be semirandom but
common.
Comment 2 Jan Chalupa 2001-11-27 11:53:13 UTC
Target milestone -> 3.3.1.
Comment 3 Jan Chalupa 2001-11-27 11:56:48 UTC
Target milestone -> 3.3.1.
Comment 4 akemr 2001-11-29 10:23:51 UTC
Fixed in release33 branch.

Above described junit testcase (I was able to reproduce with) now 
works fine for me.
Comment 5 akemr 2001-12-03 08:21:28 UTC
*** Issue 18250 has been marked as a duplicate of this issue. ***
Comment 6 Marian Mirilovic 2003-01-15 13:10:16 UTC
verified, closed
Comment 7 Quality Engineering 2008-12-23 08:34:25 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo