Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168223 - [sFTP] Private key with passphrase problem
[sFTP] Private key with passphrase problem
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: FTP Support
6.x
PC Windows 7
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
67patch1-verified
:
: 163345 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-07 13:47 UTC by hurrycane
Modified: 2009-07-20 12:59 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
message.log (22.45 KB, text/plain)
2009-07-07 17:07 UTC, hurrycane
Details

Note You need to log in before you can comment on or make changes to this bug.
Description hurrycane 2009-07-07 13:47:35 UTC
I`m trying to upload on save on a sFTP account and netbeans gives me the "Auth failed" error.
My private key is saved directly from ubuntu(where I set up the SFTP). I tested the connection with SmartFTP and WinSCP
and it works perfectly. I tried saving the key to a Windows compliant file and it does the same.
My private key is a DSA one and has a pass-phrase. If i leave the password field empty i`m not prompted for password or
for other information.
This bug happens from the version on all version >6.7, i tried the nightly build as well.
Please help me if i`m doing something wrong or if it`s a bug fix it.
Thank you very much!
Bogdan Gaza
Comment 1 Tomas Mysik 2009-07-07 13:56:05 UTC
Reporter, could you please provide exact steps to reproduce? That would help us a lot.
Filipe, could you please then try to reproduce? Thanks.
Comment 2 hurrycane 2009-07-07 14:30:58 UTC
Here are the steps:
1. File > New Project. Next. Next. I end up at Run Configuration. I choose Remote Website(FTP,SFTP) then i hit Manage.
2. I give a connection name(Test Server) and i choose SFTP. Then i fill up hostname, i change the port because my ssh
server is running on a different port. I fill up username, i leave password empty and at private key file I browse to my
desktop where the id_dsa file is exactly as my ssh-keygen -t dsa command created it in ubuntu.
3. At known hosts file i leave the field blank.
4. At initial directory i put my /home/username path
5. Hit test
6. RSA key fingerprint - hit yes.
7. Cannot connect to server myserver.name (Cause: Auth fail) 
Comment 3 Tomas Mysik 2009-07-07 14:34:53 UTC
Could you please start NetBeans with:
-J-Dorg.netbeans.modules.php.project.connections.level=500
do the steps again and then attach (do NOT copy & paste please) the IDE log (can be found in <netbeans-

Thanks a lot.
Comment 4 hurrycane 2009-07-07 14:53:44 UTC
Sorry i didn`t understand where the log is.
In my mail there was only this: (can be found in <netbeans-

Cheers!
Bogdan
Comment 5 Filip Zamboj 2009-07-07 16:12:56 UTC
it's in <userdir>/var/log/messages.log. Path to userdir is shown in Help -> About in IDE. Thanks. 
Comment 6 hurrycane 2009-07-07 17:07:06 UTC
Created attachment 84458 [details]
message.log
Comment 7 Tomas Mysik 2009-07-08 08:52:37 UTC
Thanks for the log file, unfortunately there's not much information there. We will try to reproduce your problem.

Thanks for reporting.
Comment 8 hurrycane 2009-07-08 08:56:25 UTC
Theoretically if you try to connect to a sFTP with a private key using Netbeans 6.7 final on Windows 7 it won`t work and
throw you the Auth failed error.
If you manage to reproduce the bug please send me an email!

Cheers!
Bogdan Gaza
Comment 9 Filip Zamboj 2009-07-09 11:14:57 UTC
thanks Bogdan, I'll do my best to reproduce it today. 
Comment 10 killroyboy 2009-07-09 19:31:02 UTC
I have confirmed the same issue on Mac OSX.  I attempted the exact same steps as hurrycane with the same result.  I also
tried to get more information from the log file, but it looks the same as the one posted already.  This is a significant
issue preventing the use of Netbeans (without an annoying work around).
Comment 11 Filip Zamboj 2009-07-13 12:59:21 UTC
reproduced on 
Product Version: NetBeans IDE Dev (Build 2009-07-12_15-04-38 )
Java: 1.6.0_13; Java HotSpot(TM) 64-Bit Server VM 11.3-b02

reproduced only for private keys with passphrase. 

@reporters: do you get this error when using private key without passphrase?  
Comment 12 hurrycane 2009-07-13 13:02:12 UTC
I confirm that if my key doesn`t has a pass-phrase the sFTP connection works.
Can you tell us when this bug is going to be fixed ? - it`s stopping me from using netbeans as my primary IDE. 
Comment 13 Tomas Mysik 2009-07-13 14:27:19 UTC
I will try to fix it for the nearest milestone. The problem could be that we are using 3rd party library so not sure
what is possible and what not. But this issue is definitely high on my todo list.
Comment 14 killroyboy 2009-07-13 16:22:37 UTC
My key does not have a passphrase.
Comment 15 Quality Engineering 2009-07-15 07:23:01 UTC
Integrated into 'main-golden', will be available in build *200907150249* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5af4c211cd73
User: Tomas Mysik <tmysik@netbeans.org>
Log: #166555: sFTP continously prompts for password on upload
#168223: sFTP Private key problem on Windows 7
Comment 16 Tomas Mysik 2009-07-15 13:57:34 UTC
Forgot to close.
Comment 17 Filip Zamboj 2009-07-15 14:02:07 UTC
verified 
Comment 18 Tomas Mysik 2009-07-16 12:29:58 UTC
*** Issue 163345 has been marked as a duplicate of this issue. ***
Comment 19 Filip Zamboj 2009-07-17 10:32:57 UTC
this one can be ported to 6.7.1 already 
Comment 20 pgebauer 2009-07-17 12:48:41 UTC
The fix has been ported into the release67_fixes repository together with issue 166555 .
http://hg.netbeans.org/release67_fixes/rev/5fb54a31af13
Comment 21 Filip Zamboj 2009-07-20 12:59:26 UTC
@reporter: don't hesitate if you face any other issue like this 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo