Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168162 - "Run in background" does not vanish Import modules" dialog
"Run in background" does not vanish Import modules" dialog
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Importer
6.x
All All
: P3 with 1 vote (vote)
: 7.4
Assigned To: Jiri Rechtacek
au-issues
:
Depends on:
Blocks: 181210
  Show dependency treegraph
 
Reported: 2009-07-06 08:31 UTC by matsa
Modified: 2013-07-19 10:24 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description matsa 2009-07-06 08:31:51 UTC
After telling NetBeans to import some of my plugins from 6.5 I decided to press "Run in background", but the "Import 
modules" dialog stayed open. This allowed me to start several import-processes in the same mannor.

I'm assuming that the desired behaviour here should have been that the dialog disappeared when I pressed "Run in 
background".
Comment 1 dlipin 2009-07-22 23:44:03 UTC
Yes, that is incorrect.

The issue is hidden in the following code of ImportManager.doImport():

wizardFinished = PluginManager.openInstallWizard (oc);
if (wizardFinished) {
    toInstall.clear ();
    checkedToInstall.clear ();
 } else {
    res = false;
}

In case the import wizard is send to background, the wizardFinished variable becames false and so nothing happens.
It is so because InstallUnitWizard.implInvokeWizard() checks the cancel status by the following line:
boolean cancelled = wizardDescriptor.getValue() != WizardDescriptor.FINISH_OPTION;

In case wizard went to background wizardDescriptor.getValue() is actually WizardDescriptor.NEXT_OPTION.
Theoretically we should change the 'cancelled' status check to 
boolean cancelled = 
     wizardDescriptor.getValue() == WizardDescriptor.CANCEL_OPTION || 
     wizardDescriptor.getValue() == WizardDescriptor.CLOSED_OPTION;

but should be done only after thorough testing for regressions.
Comment 2 Jiri Rechtacek 2013-07-19 10:24:44 UTC
fixed in NetBeans 7.4 Beta


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo