Bug 168108 - SQL editor should focus at editor after close Find feature instead Connection combo box
SQL editor should focus at editor after close Find feature instead Connection...
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Libor Fischmeistr
issues@db
67patch1-verified
: NETFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-04 02:07 UTC by Michel Graciano
Modified: 2014-01-07 10:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Proposed patch (2.62 KB, patch)
2009-07-06 18:42 UTC, Michel Graciano
Details | Diff
An better patch (3.55 KB, text/plain)
2009-07-07 17:27 UTC, Michel Graciano
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Graciano 2009-07-04 02:07:28 UTC
[ BUILD # : 200906241340 ]
[ JDK VERSION : 1.6.* ]

1. Open any SQL editor
2. Ctrl + F to open Find feature
3. Press ESC to cancel the find
The focus goes to Connection combo box instead editor.
Comment 1 Michel Graciano 2009-07-06 18:42:41 UTC
Created attachment 84408 [details]
Proposed patch
Comment 2 Michel Graciano 2009-07-06 18:45:20 UTC
I attached an proposal patch. I am not sure if it is the better way to solve it, but define combo as not focusable, as
did with buttons, is not a choice since it broke the shortcut. Ideas are welcome.
Maybe we can track it by NetFIX if you agree ;)

Regards
Comment 3 Michel Graciano 2009-07-07 17:27:52 UTC
Created attachment 84460 [details]
An better patch
Comment 4 Michel Graciano 2009-07-07 17:30:11 UTC
IMHO this second patch is much better. Please review it when possible.

Regards
Comment 5 Jiri Rechtacek 2009-07-08 16:39:16 UTC
Thanks for the patch. I'm going to review it and let you know asap. Thanks
Comment 6 Michel Graciano 2009-07-08 16:53:55 UTC
If you don't mind, I wish to mark this as tracked by NetFIX program.

Thanks in advance.
Comment 7 Jiri Kovalsky 2009-07-08 18:04:31 UTC
Jirko, Michel only wants to add this bug to the pool [1] of bugs that were patched by community. I think that's OK,
isn't it?

[1] http://wiki.netbeans.org/NetFIXIssues
Comment 8 Jiri Rechtacek 2009-07-09 19:52:21 UTC
Michel, your patch looks good and works for me. I'm integrating into codeline. I also add NETFIX into issue's keywords.
Thanks for the fix
Comment 9 Jiri Rechtacek 2009-07-09 19:59:08 UTC
core-main/rev/45bf306ec44f
Comment 10 Jiri Rechtacek 2009-07-09 20:02:46 UTC
Btw. the same problem I found while editing a form file (in the edit mode). After cancel the fix the focus returns to
[Edit][Design] buttons.
Comment 11 Quality Engineering 2009-07-10 05:42:39 UTC
Integrated into 'main-golden', will be available in build *200907100200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/45bf306ec44f
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #168108: SQL editor should focus at editor after close Find feature instead Connection combo box; (applied hmichel's patch)
Comment 12 Michel Graciano 2009-07-10 12:59:44 UTC
@jrechtacek I filed issue #168397 and I will take a look at it too and thanks for quick review and integration.
BTW I will mark this as 67patch-candidate, probably it could be transplanted to 6.7 code base for patch 2 if we have one
since it probably is late for patch 1. I will verify it as soon I finish the download. ;)

Regards
Comment 13 Michel Graciano 2009-07-10 13:23:38 UTC
v.
Comment 14 pgebauer 2009-07-13 09:51:20 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/3988cd215d53
Comment 15 David Strupl 2012-12-18 14:57:10 UTC
As Standa points out here:
http://netbeans.org/bugzilla/show_bug.cgi?id=168397#c14
The patch applied in this issue is also suffering from the flaw that I have explained when rollbacking the fix in 168397. Namely when instantiating toolbar presenter for this action the AWT waits for the editor pane to be fully initialised. This is not very good from the performance point of view. Please consider rollbacking this change as well.

I am just reopening the issue - please have a look and potentially revert ... Thanks.
Comment 16 Libor Fischmeistr 2014-01-07 10:29:09 UTC
Tried to reproduce with 7.4 and this bug does not appear anymore.

Closing as WORKSFORME.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo