Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 168032 - A lot of unresolved identifiers in the modified file
A lot of unresolved identifiers in the modified file
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vladimir Voskresensky
issues@cnd
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-07-02 13:37 UTC by soldatov
Modified: 2009-07-17 13:58 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2009-07-02 13:37:57 UTC
Sometimes (it is not a stable problem) I see a lot of unresolved identifiers in the modified file.

Scenario:
- Create new Freeway project
- Open maniac.cc file
==> file have not unresolved identifiers
- Modify it
==> A lot of unresolved identifiers in file
Comment 1 Vladimir Voskresensky 2009-07-02 13:41:21 UTC
I have seen it on several computers for different users. 
Comment 2 Vladimir Voskresensky 2009-07-02 13:43:12 UTC
it occurs when HL clients starts to recalculate themselves and users press Save on this time and file was reparsed
concurrently. The issue is in cached "false" states
Comment 3 Vladimir Voskresensky 2009-07-02 13:44:34 UTC
fixed:
http://hg.netbeans.org/cnd-main?cmd=changeset;node=660421c2960b
Comment 4 soldatov 2009-07-03 10:02:52 UTC
verified in latest build
Comment 5 pgebauer 2009-07-03 12:30:19 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/bf57fd01852a
Comment 6 dnikitin 2009-07-15 17:05:56 UTC
verified in IDE 6.7.1 RC (Build 200907150227)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo