Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167907 - wrong indent of /** comment
wrong indent of /** comment
Status: RESOLVED DUPLICATE of bug 162320
Product: php
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC Windows Vista
: P3 (vote)
: 6.x
Assigned To: Tomasz Slota
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 17:06 UTC by darthdeus
Modified: 2009-08-10 15:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description darthdeus 2009-06-30 17:06:40 UTC
I found problem with code formatting in Netbeans 6.7 in php project.

When I have php file like this one (bug appears even in bigger classes)
<?php
class foo {
    /** bar */
    private $bar;
}
?>

and do "format code", Netbeans indent it like this

<?php
class foo {
/** bar */
    private $bar;

}
?>

which is obviously wrong. This happens only to the first field, in the class. When there is another, not commented,
field before, it doesn't happen, like this one

<?php
class foo {
    private $bar;
    /** bar */
    private $baz;
}
?>

then it is formattec correctly
Comment 1 Tomasz Slota 2009-08-10 15:55:37 UTC
already fixed as issue 162320
Comment 2 Tomasz Slota 2009-08-10 15:56:12 UTC
.
Comment 3 Tomasz Slota 2009-08-10 15:56:41 UTC

*** This issue has been marked as a duplicate of 162320 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo