Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167881 - OutOfMemory during parsing of source
OutOfMemory during parsing of source
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
67patch1-verified
:
: 168419 168503 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 12:43 UTC by tboerkel
Modified: 2009-07-17 14:25 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
dump file (41.45 KB, text/plain)
2009-06-30 13:00 UTC, tboerkel
Details
dump file (41.55 KB, text/plain)
2009-06-30 13:00 UTC, tboerkel
Details
dump file (39.17 KB, text/plain)
2009-06-30 13:00 UTC, tboerkel
Details
messages.log (41.95 KB, text/plain)
2009-06-30 13:01 UTC, tboerkel
Details
metrics (95.25 KB, text/xml)
2009-06-30 13:01 UTC, tboerkel
Details
uigestures (127.75 KB, text/xml)
2009-06-30 13:03 UTC, tboerkel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tboerkel 2009-06-30 12:43:17 UTC
I just started NB 6.7, opened one of our projects and clicked into a source -> OutOfMemory. It could not even report the
issue from within NB. 512 MB was not enough. Maybe a memory leak. Attaching everything I have of the incident.
Comment 1 tboerkel 2009-06-30 13:00:03 UTC
Created attachment 84177 [details]
dump file
Comment 2 tboerkel 2009-06-30 13:00:20 UTC
Created attachment 84178 [details]
dump file
Comment 3 tboerkel 2009-06-30 13:00:47 UTC
Created attachment 84179 [details]
dump file
Comment 4 tboerkel 2009-06-30 13:01:15 UTC
Created attachment 84180 [details]
messages.log
Comment 5 tboerkel 2009-06-30 13:01:51 UTC
Created attachment 84181 [details]
metrics
Comment 6 tboerkel 2009-06-30 13:03:02 UTC
Created attachment 84182 [details]
uigestures
Comment 7 tboerkel 2009-06-30 13:17:50 UTC
I have to raise the priority, because I cannot work with NB 6.7 because of this.

Also, I cannot attach the heap dump (as zip), because it is 161 MB.
Comment 8 tboerkel 2009-06-30 13:22:31 UTC
This happens on ANY of our sources. Just open 3 small Java sources -> OOM. This is a J2SE project.

I have standard settings and Java tasklist disabled.
Comment 9 tboerkel 2009-06-30 13:26:47 UTC
This is interesting: If I ENABLE Java tasklist and let it finish its scanning, then I can open sources without OOM.
Comment 10 tboerkel 2009-06-30 13:30:33 UTC
This is fatal, because disabling the tasklist was recommended by a popular german news service:

http://www.heise.de/newsticker/NetBeans-6-7-setzt-Fokus-auf-Maven-und-Kenai-Integration--/meldung/141249

Comment 11 David Strupl 2009-07-07 15:47:35 UTC
Can you please attach the heap dump(s) here:
http://editor.netbeans.org/servlets/ProjectDocumentList
The heap dump is crucial for resolving OOME - also can you increase your heap size to check whether it helps?
Comment 12 David Strupl 2009-07-07 16:09:25 UTC
BTW are you using JavaFX modules? Can you tell me which version? The ones that shipped with NB 6.5.1? Thanks for the info.
Comment 13 tboerkel 2009-07-08 05:57:20 UTC
I am not using the JavaFX modules. This is a fresh install with a fresh user dir.

The machine has 4 GB of memory, so NetBeans already allocates 512 MB. That should be enough to open 3 Java sources. And
it always (before 6.7) was enough. Although I never disabled the tasklist in earlier versions.

Uploaded the heap dump: http://editor.netbeans.org/servlets/ProjectDocumentList?folderID=356
Comment 14 David Strupl 2009-07-09 12:57:43 UTC
It seems like the memory is filled by javac but assigning to Dusan to investigate and fix. Max, if you are able to fix
it please take it back and go for it but from my chair it seems like Dusan's territory.
Comment 15 Dusan Balek 2009-07-13 10:52:04 UTC
Are you able to reproduce the issue in the current dev build (I have fixed a memory leak in the initial scanning two
weeks ago)? Thanks.
Comment 16 David Strupl 2009-07-13 12:51:55 UTC
Dusan, do you have the issue number of the fixed leak or changeset that fixed it? QA wants to have the fix for this in
patch1 ...
Comment 17 Dusan Balek 2009-07-13 14:42:31 UTC
http://hg.netbeans.org/main-silver/rev/3575a6304958 has been already ported into patch1 (see issue #166800).
Comment 18 David Strupl 2009-07-13 16:01:41 UTC
It would be great if tboerkel can verify that it is ok in today's build from

http://bits.netbeans.org/6.7/fixes/

after the today's build is actually published there. Verification in the trunk would be good as well since we could then
close this issue as fixed (if it is fixed in the trunk).
Comment 19 tboerkel 2009-07-14 09:54:01 UTC
I just tested today's build (6.7.1 RC). The OOM is gone allright-

BUT: It does project scanning on opening of a project, despite the fact that I have turned Java Tasklist OFF. 

But the whole idea behind turning the Java Tasklist OFF (as suggested by the german news service) was to get rid of that
annoying "scanning".
Comment 20 Dusan Balek 2009-07-14 12:15:29 UTC
Based on the last tboerkel's comment, closing as fixed.

BTW: All NB 6.0 - 6.5 releases perform scanning on opening of a project regardless the Java Tasklist is ON or OFF. Only
rescanning of dependent files on modifications is not performed if the Java Tasklist is OFF. This is changed in NB 6.7.
Comment 21 Marian Mirilovic 2009-07-14 16:13:08 UTC
v.
Comment 22 Dusan Balek 2009-07-16 17:07:28 UTC
*** Issue 168503 has been marked as a duplicate of this issue. ***
Comment 23 Jiri Prox 2009-07-16 17:19:36 UTC
v in 6.7.1
Comment 24 Dusan Balek 2009-07-17 14:25:00 UTC
*** Issue 168419 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo