Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167849 - Java Class Library always warns "Not copying the libraries"
Java Class Library always warns "Not copying the libraries"
Status: RESOLVED DUPLICATE of bug 70077
Product: java
Classification: Unclassified
Component: Project
6.x
All All
: P4 (vote)
: 7.0
Assigned To: Tomas Zezula
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-30 03:49 UTC by _ gtzabari
Modified: 2010-12-06 19:03 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2009-06-30 03:49:15 UTC
1) Create a new Java Class Library
2) Compile
3) The output window always warns "Not copying the libraries" which sounds alarming.

If this error message is harmless, please suppress it. If not, please fix it.
Comment 1 _ gtzabari 2009-06-30 03:50:40 UTC
Please note this may be somehow related to http://www.nabble.com/Not-copying-libs-to-dist-lib-td17395968.html
Comment 2 Jiri Prox 2009-07-13 11:50:36 UTC
Not so serious IMHO
Comment 3 javor_nik 2010-12-04 08:30:54 UTC
I'm facing such an error when I add a directory to project libraries (Add JAR/Folder):

"
Created dir: <myproject>/dist
<myproject>/resources is a directory or can't be read. Not copying the libraries.
Not copying the libraries.
"

---
As result: libraries (other jars) are in fact not copied to dist/lib at all. Which is a problem.

---
What I'm trying to achieve is to add a directory (not jar) to the runtime classpath (to load configuration files resources in my case).


Such a problem is described in various forums: e.g. http://staff.blog.ui.ac.id/jp/2009/06/09/netbeans-failed-to-include-library/


The problem is reproduced both with Netbeans 6.9.1 and current Netbeans 7.0 beta (Build 201011152355).
Comment 4 Tomas Zezula 2010-12-06 19:03:02 UTC
Duplicate of #70077.
For NB 7.0 the behavior was changed not to ignore the non folder resources.

*** This bug has been marked as a duplicate of bug 70077 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo