Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167827 - Respect sub projects as well when commiting/viewing parent project
Respect sub projects as well when commiting/viewing parent project
Status: RESOLVED DUPLICATE of bug 159543
Product: versioncontrol
Classification: Unclassified
Component: Mercurial
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 19:24 UTC by psartini
Modified: 2009-06-30 07:39 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description psartini 2009-06-29 19:24:50 UTC
Not sure if this is a VCS or a Maven issue.
If you have sub projects (maven) the vcs operations just use the specific sub project. Since they are all in one 
repository, it would make sense to commit all of them at once.

Example:
- Parent Project (POM)
-- Webproject (WAR)
-- Backend (JAR)

I would expect that the Parent Project does commit its sub projects as well. Right now there is no possibility to 
commit everything at once if code changes happened accross sub modules.
Comment 1 Ondrej Vrabec 2009-06-30 07:39:52 UTC
Projects and Files view apply only on projects, all together can be committed from the Favorites view. See issue 159543.

*** This issue has been marked as a duplicate of 159543 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo