Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167814 - Go to Declaration doesn't work for some methods from libraries
Go to Declaration doesn't work for some methods from libraries
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Editing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-29 15:09 UTC by Erno Mononen
Modified: 2009-07-15 12:21 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2009-06-29 15:09:23 UTC
E.g. for render_partial in Rails actionpack/lib/action_view/partials.rb. Reported on the user list, see http://
forums.netbeans.org/topic13752.html
Comment 1 Erno Mononen 2009-07-01 08:05:42 UTC
Seems to be caused by two things:
- multiple includes of format 'include A,B,C' were not being indexed correctly, only the first arg was indexed. This is 
fixed now in 28a3476e150a.
- after getting the index for a non-project file (e.g. for a file in a gem), QuerySupport is not able to find the index 
folder. This might be a bug either in the indexing infrastructure or in the ruby indexer, not sure yet.
Comment 2 Erno Mononen 2009-07-02 12:17:43 UTC
Fixed in 46851b54654c.

The latter problem was caused by RubyPlatform#getSystemRoot(FileObject) returning the Gem home location for all the 
files under it, i.e. for every file from a gem. This was problematic since the gem home directory itself is not an 
indexed root; only the individual gem libs are.
Comment 3 Erno Mononen 2009-07-02 15:53:51 UTC
Just a note for sustaining when transplanting the fix, both of these changesets need to be transplanted:

http://hg.netbeans.org/ruby-main/rev/28a3476e150a
http://hg.netbeans.org/ruby-main/rev/46851b54654c





Comment 4 Quality Engineering 2009-07-03 05:58:54 UTC
Integrated into 'main-golden', will be available in build *200907030200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/46851b54654c
User: Erno Mononen <emononen@netbeans.org>
Log: #167814: Go to Declaration doesn't work for some methods from libraries
Comment 5 Petr Blaha 2009-07-03 09:19:28 UTC
v.
Comment 6 pgebauer 2009-07-07 11:17:02 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/a1790bceb200


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo