Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167755 - Can not run or deploy an EAR project in 6.7 RC3. The Ant project thinks the user has cancelled the operation apparently per the output window. Definitely no stop button has been pressed.
Can not run or deploy an EAR project in 6.7 RC3. The Ant project thinks the u...
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
67patch1-verified
:
: 165323 166993 168019 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-28 19:31 UTC by _ wadechandler
Modified: 2009-09-18 12:22 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log file (255.92 KB, text/plain)
2009-06-28 19:32 UTC, _ wadechandler
Details
Older log file (1.11 MB, text/plain)
2009-06-28 19:33 UTC, _ wadechandler
Details
Test project...has simple EJB-JAR (with no EJBS) and a WAR module (39.44 KB, application/x-compressed)
2009-06-28 19:36 UTC, _ wadechandler
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ wadechandler 2009-06-28 19:31:03 UTC
I have an EE EAR project with an EJB-JAR and a WAR module. I can debug the project, but I can not run or deploy it. All
I consistently receive from the IDE is:

library-inclusion-in-manifest:
C:\projects\edmr\edmrgf\nbproject\build-impl.xml:196: The following error occurred while executing this line:
C:\projects\edmr\edmrgf\edmrgf-war\nbproject\build-impl.xml:428: The following error occurred while executing this line:
C:\projects\edmr\edmrgf\edmrgf-war\nbproject\build-impl.xml:245: org.netbeans.modules.java.source.ant.UserCancel
BUILD FAILED (total time: 2 seconds)

Clean and build does not help. I am able to run debug however. But, that means the IDE attaches etc, and it doesn't run
at normal speed when I want to examine all my functionality.

I can reproduce by creating a new EE EAR project and selecting all the default options then simply try to run the EAR
project. I am using GF 2.1. If needed I should be able to package my user directory and even my installation directory
and place some where for someone to download if that will help.
Comment 1 _ wadechandler 2009-06-28 19:32:35 UTC
Created attachment 84096 [details]
Log file
Comment 2 _ wadechandler 2009-06-28 19:33:15 UTC
Created attachment 84097 [details]
Older log file
Comment 3 _ wadechandler 2009-06-28 19:34:01 UTC
Sample project I created to test will be attached next.
Comment 4 _ wadechandler 2009-06-28 19:36:05 UTC
Created attachment 84098 [details]
Test project...has simple EJB-JAR (with no EJBS) and a WAR module
Comment 5 _ wadechandler 2009-06-28 19:59:04 UTC
I have copied my userdir to another folder, deleted my file history, and deleted my cache just to reduce things. I then
ran the IDE using this other userdir, and the problem persists. I have installed some modules from the UC. I have
noticed this does not install those modules into the userdir, but instead installs them into the installation directory.
By doing this, the only way I have to go back to a really fresh install would be to completely uninstall versus a new
userdir. Seems the default would be to update the userdir versus the install directory. The point is I can not test with
a pure new userdir to see if it is caused by some other installed module. This is on Windows XP Pro SP 3 using JDK 1.6_14
Comment 6 Marian Mirilovic 2009-06-29 10:54:43 UTC
mmocnak, 
could you please look at this issue ? Thanks in advance.
Comment 7 Petr Jiricka 2009-06-29 13:00:02 UTC
I was able to reproduce using the following steps (Mac OS X 10.5.7, 1.6.0_13, NetBeans 6.7 final):
1. Starting with a fresh userdir, register GlassFish v2.1 through Window -> Services
2. Open the sample project attached by Wade:
http://www.netbeans.org/nonav/issues/showattachment.cgi/84098/EnterpriseApplicationTest.zip
3. Run the project

Then the exception appears. For me, the workaround was to open all the subprojects of the EAR, and to clean/build the
EAR project - this helped. Still, this is an ugly bug.
Comment 8 _ wadechandler 2009-06-29 15:18:11 UTC
I tried, and I can not perform a clean and build with all the projects opened and it help. If you create a new project
as I did, new EAR project, default options, with GFv2.1 selected, does it exhibit the bug as well? I'm curious if it is
only projects created from my installation. Too, I'm curious if a new installation would have the same affect or not, or
if it is only after installing certain modules. The fact the IDE updates my installation directory versus my user
directory by default means to test that theory I would have to uninstall and make a new installation to find out :-S,
but just to be clear I'm using the complete 6.7 RC3 installation, the one with EE, PHP, and C++. Too I have some modules
installed from the update center. Thanks.
Comment 9 Petr Jiricka 2009-06-30 14:49:25 UTC
I am cc'ing Dusan - class org.netbeans.modules.java.source.ant.UserCancel is related to Compile On Save I believe.
Dusane, do you have any ideas about what could be the problem?

> If you create a new project as I did, ..., does it exhibit the bug as well? 

Not for me.
Comment 10 Dusan Balek 2009-07-01 09:34:58 UTC
Fixed in jet-main.

http://hg.netbeans.org/jet-main/rev/20281b4d271f
Comment 11 Martin Schovanek 2009-07-03 09:44:58 UTC
Verified in continuous build by QE.
Comment 12 Quality Engineering 2009-07-03 17:38:46 UTC
Integrated into 'main-golden', will be available in build *200907031400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/20281b4d271f
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #167755: Can not run or deploy an EAR project in 6.7 RC3. The Ant project thinks the user has cancelled the operation apparently per the output window. Definitely no stop button has been pressed - fixed.
Comment 13 _ wadechandler 2009-07-06 22:18:36 UTC
Quick question. I'm trying to figure out if I need to file another bug report, or if this issue would cause this as
well. After I start debugging an application and it is deployed. If I modify some other files and then either click on
debug again or have it set to auto deploy on save, should the EJB-JAR from the EAR project be auto deployed successfully
if I'm using an IDE with this issue? If not, then I don't need to file another bug report, as this issue should address
that, but if so then I think I need to file another issue. Right now with GFv2.1 I'm having to use the admin web
interface for the instance, click stop debug in NB, undeploy the application, clean and build, and then click debug
again. Otherwise, nothing gets changed on the server, and I only receive errors etc that this that doesn't exist in EJBs
in my JSP pages. Seems the JSP pages get redeployed, but EJBs do not get redeployed without going through the steps above.

Thanks
Comment 14 David Konecny 2009-07-07 00:56:03 UTC
I used to experience this problem regularly on freshly created web project's without any Java source - creating a Java
soruce fixed it for me. Nobody else apart from me was able to reproduce it though.
Comment 15 Petr Jiricka 2009-07-07 06:37:52 UTC
Wade, regarding the deploy-on-save question, I am cc'ing Petr Hejl who implemented this feature. You may want to file a
new issue regardless.
Comment 16 Petr Hejl 2009-07-07 08:28:29 UTC
Wade, autodeploy in debug mode is not supposed to work so far. There could be one enhancement - to perform apply changes
automatically.

Autodeploy can't be used for other resources (which involve redeploy in background) because the deployment itself could
be blocked by the suspended thread in the server. This would expose a deadlock.
Comment 17 pgebauer 2009-07-07 10:12:56 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/6a3ad8288841
Comment 18 Petr Jiricka 2009-07-07 13:43:36 UTC
*** Issue 166993 has been marked as a duplicate of this issue. ***
Comment 19 _ pcw 2009-07-13 14:20:19 UTC
*** Issue 165323 has been marked as a duplicate of this issue. ***
Comment 20 Jindrich Sedek 2009-07-17 13:04:32 UTC
verified in 6.7.1 RC
NetBeans IDE 6.7.1 RC (Build 200907162301)
Comment 21 Petr Jiricka 2009-09-18 12:22:32 UTC
*** Issue 168019 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo