Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167710 - IDE freezes for 30s after closing mvn project
IDE freezes for 30s after closing mvn project
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Bugzilla
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Stupka
issues@connecteddeveloper
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-26 16:41 UTC by Marian Mirilovic
Modified: 2009-07-27 09:20 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
thread-dump (23.10 KB, text/plain)
2009-06-26 16:41 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-06-26 16:41:12 UTC
NB 6.7 FCS, JDK 6u14 64b, Ubuntu 9.04 64b

Steps I've got into freeze:
- opened mvn project
- created another J2SE project from scratch
- working with that for a while (half day) ... reading emails/meetings/....
- returned back tried to work with the J2SE project
- realized I have opened mvn project that I hadn't touched for a while
- closed project from popup menu
-> IDE frozen for ~30s (see attached thread dump)

I had opened Keni Dashboard (opened in this IDE session), hadn't been logged in, hadn't used any Kenai projects ....
Comment 1 Marian Mirilovic 2009-06-26 16:41:38 UTC
Created attachment 84061 [details]
thread-dump
Comment 2 Tomas Stupka 2009-06-30 11:43:58 UTC
should be fixed since

1657cfc3922f	Fri May 29 16:52:15 CEST 2009	Tomas Stupka <tstupka@netbeans.org>
do not trigger repositories on a simple getDefault() call by persistensmanager
Comment 3 Petr Dvorak 2009-07-02 12:57:11 UTC
I am unable to reproduce the issue. If it still persists, please reopen. Verified in

Product Version: NetBeans IDE Dev (Build 200907020200)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)
Comment 4 pgebauer 2009-07-03 12:22:40 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/fbe4820adc31


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo