Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167665 - org.apache.lucene.search.BooleanQuery$TooManyClauses: maxClauseCount is set to 1024
org.apache.lucene.search.BooleanQuery$TooManyClauses: maxClauseCount is set t...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: David Simonek
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 18:18 UTC by fsoares
Modified: 2009-07-20 14:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.83 KB, text/plain)
2009-06-25 18:18 UTC, fsoares
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fsoares 2009-06-25 18:18:45 UTC
Build: NetBeans IDE 6.7 RC3 (Build 200906142201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.29.4-167.fc11.x86_64, amd64

User Comments:
fsoares: Using de maven dialog box add dependency

fsoares: Adding lib dependency in a maven project

kawazu428: tried to add a dependency via maven "add dependency" dialogue, the exception being thrown while tab'bing to "ArtifactId" field

tboudreau: Searched for groupid org.apache.wicket in Add Dependency for a Maven project

mkleint: typing groupid in add dependency dialog, then tabbed to artifactid field



Stacktrace: 
org.apache.lucene.search.BooleanQuery$TooManyClauses: maxClauseCount is set to 1024
        at org.apache.lucene.search.BooleanQuery.add(BooleanQuery.java:165)
        at org.apache.lucene.search.BooleanQuery.add(BooleanQuery.java:156)
        at org.apache.lucene.search.PrefixQuery.rewrite(PrefixQuery.java:54)
        at org.apache.lucene.search.BooleanQuery.rewrite(BooleanQuery.java:370)
        at org.apache.lucene.search.IndexSearcher.rewrite(IndexSearcher.java:151)
        at org.apache.lucene.search.Query.weight(Query.java:94)
Comment 1 fsoares 2009-06-25 18:18:55 UTC
Created attachment 84022 [details]
stacktrace
Comment 2 Exceptions Reporter 2009-06-25 18:19:09 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=151957
Comment 3 Milos Kleint 2009-06-26 07:42:12 UTC
possibly duplicate of #166313
Comment 4 Exceptions Reporter 2009-06-30 10:03:24 UTC
This issue already has 9 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=151957
Comment 5 David Simonek 2009-07-10 09:17:19 UTC
should be solved (yes I tested it) along with the fix of 167729 issue. 
Comment 6 Jaroslav Pospisil 2009-07-13 09:08:40 UTC
v.
Comment 7 pgebauer 2009-07-13 17:22:27 UTC
The fix has been ported into the release67_fixes repository together with the fix of issue 167729 .
http://hg.netbeans.org/release67_fixes/rev/541ccff28917


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo