Bug 167661 - Template file does not read project.properties
Template file does not read project.properties
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Project
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
:
: 168441 170542 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-25 16:42 UTC by johnjackson
Modified: 2009-08-19 09:38 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description johnjackson 2009-06-25 16:42:26 UTC
The project.license key in the nbproject/project.properties file does not seem to be read in certain project types, at
least PHP and Python projects, but it does work in Java projects.

Steps to reproduce:

1. Create PHP project
2. Open nbproject/project.properties and add in "project.license=apache20"
3. Create new PHP file

Expected result:
New PHP file is created with the apache20 license at the top.

Actual result:
PHP file contains the default license at the top.

Workaround:
It can be made to work by editing the PHP file template and setting the license line to <#include
"../Licenses/license-apache20.txt">

The exact same steps work with Java projects.
Comment 1 Tomas Mysik 2009-07-13 08:49:24 UTC
*** Issue 168441 has been marked as a duplicate of this issue. ***
Comment 2 Tomas Mysik 2009-07-15 16:47:25 UTC
Fixed, please verify. Thanks.
http://hg.netbeans.org/web-main/rev/5b08c367d748
Comment 3 Quality Engineering 2009-07-16 05:59:33 UTC
Integrated into 'main-golden', will be available in build *200907160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5b08c367d748
User: Tomas Mysik <tmysik@netbeans.org>
Log: #167661: Template file does not read project.properties
Comment 4 johnjackson 2009-07-19 16:42:05 UTC
Tested with daily build 200907171401 and can confirm it now uses the license template I added. Thanks! Not sure if this
is significant, but the built-in licenses, such as apache20 and mit, are blank.

I believe this bug still exists for Python projects though, and possibly others. Should another bug be opened for those?
Comment 5 Tomas Mysik 2009-07-20 09:04:45 UTC
> Should another bug be opened for those?

Yes, please. Add this issue for more information and possible fix. Thanks a lot.
Comment 6 Tomas Mysik 2009-08-19 09:38:41 UTC
*** Issue 170542 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo