Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167562 - NB IDE Appears to have a partial crash
NB IDE Appears to have a partial crash
Status: RESOLVED DUPLICATE of bug 119617
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 21:59 UTC by mscribner
Modified: 2009-08-19 15:31 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Requested messages.log file (56.15 KB, text/plain)
2009-06-24 16:01 UTC, mscribner
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mscribner 2009-06-23 21:59:01 UTC
After using NB for about 30 minutes. It appears that the IDE has some sort of internal crash that it can't recover from. I 
have line numbers enabled, and after 30 minutes of normal work, these line numbers disappear and the IDE does not 
recognize keystrokes like the backspace, delete, and copy/paste stops working. I have to either close out all open files 
and reopen them, or close the entire application down. This happens with version 6.5 and 6.5.1. I have the full NB package 
installed with the Python package. I am not sure if it is the IDE itself suffering from a partial crash or if java is 
crashing. I tried poking around the system logs and I can not find anything help. This issue occurs when it sits idle or 
while being used. I am willing to supply further information regarding this issue in the hope of discovering the cause of 
this defect.
Comment 1 Marian Mirilovic 2009-06-24 11:49:39 UTC
Thanks for your report .. please look at your userdir : http://wiki.netbeans.org/FaqWhatIsUserdir and attach
messages.log file. 
Comment 2 mscribner 2009-06-24 16:01:20 UTC
Created attachment 83994 [details]
Requested messages.log file
Comment 3 mscribner 2009-06-26 17:13:47 UTC
I'm not sure if this is related, but I just noticed this error:

java.lang.NullPointerException
	at com.sun.java.swing.plaf.windows.WindowsTreeUI.ensureRowsAreVisible(WindowsTreeUI.java:74)
	at javax.swing.plaf.basic.BasicTreeUI.toggleExpandState(BasicTreeUI.java:2213)
	at javax.swing.plaf.basic.BasicTreeUI.handleExpandControlClick(BasicTreeUI.java:2196)
	at javax.swing.plaf.basic.BasicTreeUI.checkForClickInExpandControl(BasicTreeUI.java:2154)
	at javax.swing.plaf.basic.BasicTreeUI$Handler.handleSelection(BasicTreeUI.java:3508)
	at javax.swing.plaf.basic.BasicTreeUI$Handler.mousePressedDND(BasicTreeUI.java:3494)
	at javax.swing.plaf.basic.BasicTreeUI$Handler.mousePressed(BasicTreeUI.java:3453)
	at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:263)
	at java.awt.Component.processMouseEvent(Component.java:6038)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
	at java.awt.Component.processEvent(Component.java:5806)
	at java.awt.Container.processEvent(Container.java:2058)
	at java.awt.Component.dispatchEventImpl(Component.java:4413)
	at java.awt.Container.dispatchEventImpl(Container.java:2116)
	at java.awt.Component.dispatchEvent(Component.java:4243)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3983)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3916)
	at java.awt.Container.dispatchEventImpl(Container.java:2102)
	at java.awt.Window.dispatchEventImpl(Window.java:2440)
	at java.awt.Component.dispatchEvent(Component.java:4243)
[catch] at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
	at org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)
Comment 4 Vitezslav Stejskal 2009-07-29 13:34:04 UTC
I'm not sure what's wrong. The log file shows nothing. This could be one of the mysterious focus problems we have been
hunting for years now. See for example issue #119617.
Comment 5 Jiri Prox 2009-08-19 15:31:52 UTC

*** This issue has been marked as a duplicate of 119617 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo