Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167531 - AssertionError: Start offset must be before the end offset. startOffset = 136, endOffset = -1
AssertionError: Start offset must be before the end offset. startOffset = 136...
Status: RESOLVED DUPLICATE of bug 167478
Product: editor
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-23 13:10 UTC by Erno Mononen
Modified: 2009-06-24 13:32 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (4.52 KB, text/plain)
2009-06-23 13:11 UTC, Erno Mononen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2009-06-23 13:10:57 UTC
This issue was originally marked as duplicate of issue 149174, that is already resolved. This issue is still valid, so this seems to be another issue, but it might be related.

Build: NetBeans IDE Dev (Build 090619)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.27-14-generic, amd64

User Comments:
emononen: Pasted the following code to a newly created .erb file:

<table>
  <tr <%= 'foo' %>> <!-- ERROR -->
    <td></td>
  </tr>
</table>



Stacktrace: 
java.lang.AssertionError: Start offset must be before the end offset. startOffset = 136, endOffset = -1
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlightImpl(OffsetsBag.java:491)
        at org.netbeans.spi.editor.highlighting.support.OffsetsBag.addHighlight(OffsetsBag.java:161)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.placeHighlights(MasterMatcher.java:301)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.highlightAreas(MasterMatcher.java:278)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher.access$500(MasterMatcher.java:63)
        at org.netbeans.modules.editor.bracesmatching.MasterMatcher$Result$1.run(MasterMatcher.java:630)
Comment 1 Erno Mononen 2009-06-23 13:11:09 UTC
Created attachment 83928 [details]
stacktrace
Comment 2 Vitezslav Stejskal 2009-06-24 13:32:08 UTC

*** This issue has been marked as a duplicate of 167478 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo