Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167399 - [67cat] after changing a file the navigation panel is slow to appear
[67cat] after changing a file the navigation panel is slow to appear
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P3 with 3 votes (vote)
: 7.2
Assigned To: Dusan Balek
issues@java
: PERFORMANCE
Depends on: 166714
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-20 04:08 UTC by nleck
Modified: 2012-09-14 12:43 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Performance regression from 6.5 to 6.7 (2.16 MB, video/ogg)
2009-06-20 04:10 UTC, nleck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nleck 2009-06-20 04:08:06 UTC
There is another performance regression even after the fix in #166714
Comment 1 nleck 2009-06-20 04:10:03 UTC
Created attachment 83834 [details]
Performance regression from 6.5 to 6.7
Comment 2 nleck 2009-06-20 04:12:30 UTC
This is on a single user, 8 core processor, 12 gigs of ram linux box. 
Comment 3 Max Sauer 2009-06-22 12:44:20 UTC
Dusane, could you please shed some light on this? Thanks.
Comment 4 nleck 2009-06-22 12:48:44 UTC
This is a performance regression in 6.7
Comment 5 Dusan Balek 2009-06-23 09:53:27 UTC
There is the same problem as described in #166714. The reason why it works in 6.5 is that in 6.5 editor
modifications did not trigger dependencies compilation. This was one of the problems causing incorrect error badges. In
6.7 we fixed that and when a class is modified in the editor, it is recompiled including all the classes that depend on
it. This may take some time depending on how many dependent classes there are.
Comment 6 nleck 2009-06-23 11:18:32 UTC
The problem is the navigation is off line too much. It's the navigation panel and the right click Navigate options that
are effected. The movie I've attached is from a single user machine, on the main unix box which is shared by a number of
the bank's developers, the performance of the navigation ( goto type etc) were bad in 6.5 and now it's worst. It's
really going to be bad news for the remaining NB developers here.

Eclipse doesn't seem to have these project scan issues at all. To make the issue worst when we're already behind is bad. 

The issue #166714 althou fixed isn't in RC3 so this is also bad.
Comment 7 Dusan Balek 2012-09-14 12:43:54 UTC
Should be already fixed. Navigator should not be blocked by the dependent files rescanning.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo