Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167338 - [67cat] NB 6.5 JavaSE projects with Web Service Clients create "${file.reference.Project.src}" folders when opened in NB 6.7
[67cat] NB 6.5 JavaSE projects with Web Service Clients create "${file.refere...
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: Milan Kuchtiak
issues@webservices
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 21:38 UTC by swpalmer
Modified: 2009-07-17 13:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Project fragment illustrating problem see comments (36.29 KB, application/x-compressed)
2009-06-19 21:20 UTC, swpalmer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description swpalmer 2009-06-18 21:38:13 UTC
[ BUILD # : 20090614220 ]
[ JDK VERSION : 1.6.* ]

I have a couple JavaSE projects that used JAX-WS/WSIT.  When I load
them in NB 6.7 I get a directory created with the name of the source
dir property (unresolved) and a couple WSDL and XSD files are dumped
in there in various subfolders.

I've tried all manner of things to "clean up" the project and build
files to see if I could make it stop.

Could this be related to defining "jaxws.endorsed.dir" in my
project.properties file?  I was doing this to use a newer build of
WSIT.. maybe I don't even need to do that if I'm running against
6u14.
Comment 1 Martin Grebac 2009-06-19 09:02:58 UTC
Would you please attach the projects or specify reproduction steps?
Comment 2 swpalmer 2009-06-19 21:20:28 UTC
Created attachment 83831 [details]
Project fragment illustrating problem see comments
Comment 3 swpalmer 2009-06-19 21:22:22 UTC
I've attached a severely crippled  and stripped down version of my project that demonstrates the error.  Simply opening 
this project will cause the bogus folder to be created.  The project can not be compiled because I have removed all of the 
source code except for a main stub and have not included dependencies.
Comment 4 Lukas Jungmann 2009-06-19 22:55:53 UTC
reproduced...

problem here is that default/expected value of "src.dir" property in project.properties was somehow replaced with a
reference to another property "${file.reference.Stream-src}" and ws related open hook is not expecting this
Comment 5 Milan Kuchtiak 2009-06-22 11:00:27 UTC
The src.dir property in project.properties was replaced most probably by the user.
(E.g. in project customizer: Project properties -> Sources section)
Unfortunately, the additional sources were removed, or project directory was moved without these sources.

WS support, or any other support, I believe, doesn't change src.dir programatically.

If you think, this is really a Netbeans issue, we need a simple example: project created in Netbeans 6.5, that cannot be
open in Netbeans 6.7. The project you've attached is too complex. Or some simple steps to reproduce the issue.
Comment 6 swpalmer 2009-06-22 15:34:41 UTC
"The src.dir property in project.properties was replaced most probably by the user."

No. It was never changed directly.

The file is in version control, and I looked back nearly three years.. it was always as it is now.

Note that I never said the project was created in 6.5... It worked in 6.5 without creating the bogus folder.  The 
original project may have been created before 6.5.

I don't understand what you mean by "the additional sources were removed"  I did remove the bulk of the source tree 
under the "src" folder because it is IP I can not share in the bug database.  But there are no additional source folders 
that aren't included in the archive.
Comment 7 Milan Kuchtiak 2009-06-22 16:39:25 UTC
Sorry, I found web services support is responsible for creating this bogus folder.

The jax-ws-catalog.xml file was implemented in Netbeans 6.7 and this implementation incorrectly creates folder specified
by meta.inf.dir property.

The workaround for 6.7 is to replace meta.inf.dir property in nbproject/project.properties with :
meta.inf.dir=src/META-INF, and you can remove that bogus directory.
Comment 8 Milan Kuchtiak 2009-06-23 12:27:27 UTC
http://hg.netbeans.org/main/rev/12c72cdad00f
Comment 9 Jaroslav Pospisil 2009-06-30 16:00:43 UTC
v.
Comment 10 pgebauer 2009-07-02 13:08:57 UTC
The changeset mentioned above looks like a fix for the issue 167228 .  Could you please confirm that it fixes IZ#167338 as well? If not, could you please 
provide a correct changeset?
Comment 11 Milan Kuchtiak 2009-07-02 13:27:48 UTC
Sorry for confusion.

The changeset mentioned above is the fix for this issue (#167338), not #167228.
Comment 12 pgebauer 2009-07-03 16:02:24 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/3dad2472ad7f
Comment 13 Jindrich Sedek 2009-07-17 13:51:56 UTC
verified in 6.7.1 RC
NetBeans IDE 6.7.1 RC (Build 200907162301)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo