Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167327 - NullPointerException at org.netbeans.modules.javahints.StaticImport.guessCandidates
NullPointerException at org.netbeans.modules.javahints.StaticImport.guessCand...
Status: RESOLVED FIXED
Product: contrib
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: TBD
Assigned To: fommil
issues@contrib
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-18 17:31 UTC by mklaehn
Modified: 2009-08-07 10:32 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.07 KB, text/plain)
2009-06-18 17:31 UTC, mklaehn
Details
mouse hovering over TODO annotation in sidebar (22.43 KB, image/png)
2009-06-22 12:23 UTC, mklaehn
Details
stacktrace (1.07 KB, text/plain)
2009-06-29 17:08 UTC, sreimers
Details
stacktrace (1.07 KB, text/plain)
2009-06-30 18:06 UTC, sreimers
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mklaehn 2009-06-18 17:31:15 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3316-on-090616)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.javahints.StaticImport.guessCandidates(StaticImport.java:435)
        at org.netbeans.modules.javahints.StaticImport.run(StaticImport.java:120)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:122)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:65)
        at org.netbeans.modules.java.source.JavaSourceAccessor$CancelableTaskWrapper.run(JavaSourceAccessor.java:288)
        at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:661)
Comment 1 mklaehn 2009-06-18 17:31:34 UTC
Created attachment 83767 [details]
stacktrace
Comment 2 mklaehn 2009-06-18 17:38:32 UTC
happened while pressing shortcut CTRL-O
Comment 3 mklaehn 2009-06-22 12:23:04 UTC
Created attachment 83869 [details]
mouse hovering over TODO annotation in sidebar
Comment 4 mklaehn 2009-06-22 12:25:57 UTC
please ignore attachment sidebar.png
it was meant for issue http://www.netbeans.org/issues/show_bug.cgi?id=167257
Comment 5 sreimers 2009-06-29 17:07:54 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3422-on-090629)
VM: Java HotSpot(TM) Client VM, 14.0-b13, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b05
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.javahints.StaticImport.guessCandidates(StaticImport.java:435)
        at org.netbeans.modules.javahints.StaticImport.run(StaticImport.java:120)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:122)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:65)
        at org.netbeans.modules.java.source.JavaSourceAccessor$CancelableTaskWrapper.run(JavaSourceAccessor.java:288)
        at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:661)
Comment 6 sreimers 2009-06-29 17:08:00 UTC
Created attachment 84140 [details]
stacktrace
Comment 7 Exceptions Reporter 2009-06-29 17:08:07 UTC
This issue already has 6 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 8 fommil 2009-06-30 11:46:50 UTC
I'll look into this tonight... didn't realise how many people it was affecting.

Simply turn off this experimental hint in the preferences if the problem is affecting you.
Comment 9 fommil 2009-06-30 11:48:22 UTC
@mklaehn lol.... thanks for saying to ignore the screenshot, it was really puzzling me!! Must read all comments first...
Comment 10 sreimers 2009-06-30 18:06:15 UTC
Build: NetBeans IDE Dev (Build nbms-and-javadoc-3422-on-090629)
VM: Java HotSpot(TM) Client VM, 14.0-b16, Java(TM) SE Runtime Environment, 1.6.0_14-b08
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.javahints.StaticImport.guessCandidates(StaticImport.java:435)
        at org.netbeans.modules.javahints.StaticImport.run(StaticImport.java:120)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:122)
        at org.netbeans.modules.java.hints.infrastructure.SuggestionsTask.run(SuggestionsTask.java:65)
        at org.netbeans.modules.java.source.JavaSourceAccessor$CancelableTaskWrapper.run(JavaSourceAccessor.java:288)
        at org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob.run(TaskProcessor.java:661)
Comment 11 sreimers 2009-06-30 18:06:25 UTC
Created attachment 84202 [details]
stacktrace
Comment 12 Exceptions Reporter 2009-06-30 18:06:40 UTC
This issue already has 7 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 13 fommil 2009-06-30 20:57:53 UTC
patch submitted that should fix this.

https://hg.netbeans.org/main/contrib/rev/936203b0dfe6
Comment 14 Exceptions Reporter 2009-07-01 16:56:36 UTC
This issue already has 8 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 15 Exceptions Reporter 2009-07-03 13:09:30 UTC
This issue already has 9 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 16 Exceptions Reporter 2009-07-07 15:22:50 UTC
This issue already has 11 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 17 Exceptions Reporter 2009-07-30 10:59:28 UTC
This issue already has 21 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 18 Exceptions Reporter 2009-08-07 10:03:49 UTC
This issue already has 24 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=152779
Comment 19 fommil 2009-08-07 10:32:32 UTC
patch attached a while ago.... new stacktraces are from old builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo