Bug 167262 - Output window hyperlinks don't work like they used to
Output window hyperlinks don't work like they used to
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Output Window
6.x
All All
: P3 (vote)
: 6.x
Assigned To: t_h
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 20:21 UTC by mclaassen
Modified: 2009-08-04 13:54 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Screenshot (145.62 KB, image/jpeg)
2009-06-17 20:25 UTC, mclaassen
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mclaassen 2009-06-17 20:21:48 UTC
I noticed using 6.7 RC3 that hyperlinks don't work as they used to.  First of all, they are not blue anymore.  There
were so much easier to locate when they were a different color.  Now, all the text is the same color.  They are valid
hyperlinks though.

Also the tab/open behavior is different.  Clicking on a hyperlink will either select a tab to an open file or open a new
tab.  However, it will never open more than one new tab.  After the first new tab is open, its contents will be replaced
by other files when a link is selected to an unopened file.

Perhaps this was done on purpose, but, at least for now, I prefer the 6.5 behavior.
Comment 1 mclaassen 2009-06-17 20:25:15 UTC
Created attachment 83724 [details]
Screenshot
Comment 2 Petr Dvorak 2009-06-17 21:00:38 UTC
Hi!

Thank you for the report. The current behaviour is as designed - the highlighting of the output view has changed in many
ways in NB6.7 (at least for Java files - each module can influence the way output is painted). I know that change like
this can be unpleasant but current colours are (subjectively speaking) quite easy to get used to.

I am closing the issue as WONTFIX (current state is as designed) but if there is too much noise on nbusers regarding
this, we will definitely consider enhancements.

With regards,

Petr Dvorak
http://wiki.netbeans.org/PetrDvorak
Comment 3 Petr Dvorak 2009-06-17 21:03:07 UTC
WONTFIX
Comment 4 mclaassen 2009-06-17 21:10:44 UTC
The high contrast of the stack traces in previous version were very helpful.  And although I can get "used" to the new
colors, I feel like something was taken away with no apparent benefit.

If the hyperlink / open window behavior is changing, it would be nice if a (ctrl-click) or something would force it to
open in a permanent tab (like a browser would do).

Comment 5 trcorbin 2009-06-17 21:19:42 UTC
I can't stand the way it locks into one editor tab like that.  It drives me nuts and I had assumed it was a bug.
Comment 6 Michel Graciano 2009-06-25 21:43:15 UTC
I really think it should be reevaluated. Some users related to me that this behaviour looks like an bug since is not so
easy to identify links as before. Please, if anyone else think it is an worse behaviour, please vote to this issue to
get it fixed in the future.

Regards
Comment 7 mclaassen 2009-06-26 14:44:07 UTC
I humbly disagree with this assessment.  

Blue is the almost universal color for hyperlinks.  I am not sure what compelled this change, but it seems like it was
just a random thing. It makes it less intuitive and different for no apparent reason or benefit.
Comment 8 mclaassen 2009-06-26 18:44:25 UTC
Here is a sample of one of my log messages:
Here is the comment I added to: http://www.netbeans.org/issues/show_bug.cgi?id=167386
I think it is very relevant here:

Here is a sample of one of my custom log message.

01:37:28[00002:04] dsi.joint.io.ApacheDConnection$MyRequestEntity.writeRequest(ApacheDConnection.java:238)Sent data to
servlet

I opened my project in eclipse and the only underlined part was the part in the parentheses "ApacheDConnection.java:238"

This is very nice.  It is blue (which indicates a link), and does not create a lot of screen clutter by underlining the
entire FQN.  I would suggest this model.

This would also allow the main color of the text to show more.  So if red was desired for stack traces, black for
something else, ...  the line would be mostly that color.  But ALL hyperlinks would be in blue.
Comment 9 Petr Dvorak 2009-07-03 07:26:24 UTC
Hi - please, you have to reopen the issue if you believe it should not be closed! Discussion under closed issues is not
very much watched... I have written the explanation of why I closed it: current behavior is as designed, therefore it is
not a defect. But you could have reopened the issue as an enhancement - it enhances current behavior... Thanks, regards,
Petr D.
Comment 10 Jindrich Sedek 2009-07-10 10:56:15 UTC
I agree that blue color is more intuitive for links maybe Ondra could look at it deeper
Comment 11 t_h 2009-07-10 11:06:02 UTC
There are two types of hyperlinks in OW - "normal" and "important". Normal (e.g. compilation warnings) hyperlinks are
still blue, important (which usually denotes error and autoscrolling stops on them) were changed to red. Important
hyperlinks used to be slightly lighter blue than normal hyperlinks. It was hard to distinguish them so they were changed.
Comment 12 Michel Graciano 2009-07-10 20:11:11 UTC
About how to trate _normal_ and _important_ links is not so easy IMO. Maybe _important_ links  should be in normal blue
(hyperlink blue) and for _normal_ probably an darker blue. Probably other users could be better opinions :D

Now, about tab behaviour, IMHO it should reuse just already opened files and for new files it should open new editors.
BTW, an Ctrl + click shortcut would be nice and it should clone the already opened editor and goes to the link position.
I don't know how tricky it should be but looks to be the natural behaviour users like to see.
Comment 13 t_h 2009-08-04 13:54:44 UTC
OW now supports partial line hyperlinks and multiple colors/hyperlinks on single line. It is possible to distinguish
warning/error by color of surrounding text so I changed default colors of both hyperlink types back to blue (core-main
#c2da2c80f723). If you want to change how hyperlinks work file an issue against ant/code.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo