Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167256 - Keyboard navigation in Projects unusably slow if something in clipboard
Keyboard navigation in Projects unusably slow if something in clipboard
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
6.x
All Windows Vista
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
67patch1-fixed
:
: 159566 168188 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-17 18:00 UTC by Tomas Pavek
Modified: 2015-12-11 14:08 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
profiling snapshot (17.21 KB, application/octet-stream)
2009-06-17 18:01 UTC, Tomas Pavek
Details
additional perf. improvements for projectui, milane please review (5.88 KB, text/plain)
2009-06-24 09:46 UTC, t_h
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Pavek 2009-06-17 18:00:21 UTC
200906150201

Even with a simple project, try to Ctrl-C on a file in projects explorer and then move around via keyboard. It's
unusably slow, the IDE totally choked up. I even got the slowness warning reporting AWT blocked for more than 1s.
Attaching the snapshot. It seems like there is no single culprit - perhaps the explorer (or the treeview) should try to
handle consecutive selection changes better.

It's ok with empty clipboard, or if there's e.g. just a text.
Comment 1 Tomas Pavek 2009-06-17 18:01:18 UTC
Created attachment 83717 [details]
profiling snapshot
Comment 2 t_h 2009-06-19 16:40:13 UTC
The reason of slowness was paste action update (especially
org.netbeans.modules.refactoring.java.ui.RefactoringActionsProvider.canCopy() is rather slow). I fixed it on explorer's
side where paste action update was invoked when not necessary. 
core-main #428c7d138e45
Comment 3 Quality Engineering 2009-06-20 08:06:05 UTC
Integrated into 'main-golden', will be available in build *200906200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/428c7d138e45
User: Tomas Holy <t_h@netbeans.org>
Log: #167256: Keyboard navigation in Projects unusably slow if something in clipboard
Comment 4 t_h 2009-06-24 09:46:48 UTC
Created attachment 83980 [details]
additional perf. improvements for projectui, milane please review
Comment 5 Milan Kubec 2009-06-26 09:27:12 UTC
The patch looks OK. Do projectui tests are pass?
Comment 6 rdelaplante 2009-07-06 19:19:54 UTC
Please have a look at issue #168188 to see if it is caused by this bug.  If yes, please include this fix in NB 6.7 patch 1. 
Comment 7 t_h 2009-07-07 07:38:51 UTC
*** Issue 168188 has been marked as a duplicate of this issue. ***
Comment 8 Marian Mirilovic 2009-07-07 09:38:56 UTC
verified
Comment 9 Marian Mirilovic 2009-07-07 09:54:53 UTC
v
Comment 10 pgebauer 2009-07-07 10:33:49 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/d0850a22f23f
Comment 11 Quality Engineering 2009-07-07 17:30:43 UTC
Integrated into 'main-golden', will be available in build *200907071400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7a94213a56b4
User: Tomas Holy <t_h@netbeans.org>
Log: #167256: additional perf. improvements.
Comment 12 Tomas Pavek 2009-09-10 12:41:41 UTC
*** Issue 159566 has been marked as a duplicate of this issue. ***
Comment 13 dasprid 2015-12-11 14:08:25 UTC
This bug seems to have been appeared again. When I have some larger image in my clipboard, the projects navigation via keyboard gets very sluggish.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo