Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167193 - [67cat] lock up in 6.7rc3
[67cat] lock up in 6.7rc3
Status: VERIFIED FIXED
Product: editor
Classification: Unclassified
Component: CSL (API & infrastructure)
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
: PERFORMANCE, REGRESSION
: 167260 (view as bug list)
Depends on:
Blocks: 166714
  Show dependency treegraph
 
Reported: 2009-06-17 01:27 UTC by nleck
Modified: 2009-06-19 15:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stack dump. (13.32 KB, text/plain)
2009-06-17 01:28 UTC, nleck
Details

Note You need to log in before you can comment on or make changes to this bug.
Description nleck 2009-06-17 01:27:46 UTC
tried to test #166714 and the editor locked up.
Comment 1 nleck 2009-06-17 01:28:22 UTC
Created attachment 83665 [details]
stack dump.
Comment 2 Vitezslav Stejskal 2009-06-17 09:23:56 UTC
IMO this is related to TLIndexer and so likely a regression caused by fixes in issue #163125.
Comment 3 Marian Mirilovic 2009-06-17 10:24:20 UTC
Thanks for report .. we'll look at it NOW. It needs to be clear what is the problem and whether we are able to fix it,
just because this is regression of fix integrated during HR.
Comment 4 Vitezslav Stejskal 2009-06-18 10:44:00 UTC
*** Issue 167260 has been marked as a duplicate of this issue. ***
Comment 5 Vitezslav Stejskal 2009-06-18 10:49:34 UTC
This in fact is not a lock up, but very bad performance of TLIndexer and GsfTaskProvider. I'm testing fix for this. IMO
we should transplant it to release67.
Comment 6 Vitezslav Stejskal 2009-06-18 11:34:25 UTC
Fixed - http://hg.netbeans.org/jet-main/rev/bcc14d72af94
Comment 7 Vitezslav Stejskal 2009-06-18 17:45:20 UTC
The fix was transplanted to release67 as http://hg.netbeans.org/release67/rev/e3974afb3975.
Comment 8 Quality Engineering 2009-06-19 07:46:10 UTC
Integrated into 'main-golden', will be available in build *200906190201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/bcc14d72af94
User: Vita Stejskal <vstejskal@netbeans.org>
Log: #167193 - fixing the way how errors/warnings are stored/retrieved from the index and how they are pushed to the tasklist
Comment 9 Jiri Prox 2009-06-19 15:23:18 UTC
the performance seems fine in 6.7fcs


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo