Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167108 - A keyboard shortcut to show a list of templates that apply to the current editor file, such as Ctrl+J.
A keyboard shortcut to show a list of templates that apply to the current edi...
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
All All
: P3 (vote)
: 8.0
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 15:01 UTC by culli
Modified: 2013-09-19 12:57 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description culli 2009-06-15 15:01:32 UTC
Would like a keyboard shortcut to show a list of templates that apply to the current editor file.  This would help to
learn the templates, such as "fore".  Even better would be to take the current "word" at the insert point and narrow the
list down.  Editors such as IntelliJ and Delphi have this feature mapped to Ctrl+J if you want to see what I'm talking
about.
Comment 1 rmichalsky 2009-06-15 15:08:58 UTC
reassigning to owner
Comment 2 markiewb 2013-03-03 23:20:53 UTC

*** This bug has been marked as a duplicate of bug 184604 ***
Comment 3 Dusan Balek 2013-09-17 08:51:01 UTC
A list of templates that apply to the current editor file is shown in code completion now (using Ctrl+Space shortcut).

http://hg.netbeans.org/jet-main/rev/514f277e3674
Comment 4 Quality Engineering 2013-09-19 12:57:17 UTC
Integrated into 'main-silver', will be available in build *201309191137* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)

Changeset: http://hg.netbeans.org/main-silver/rev/514f277e3674
User: Dusan Balek <dbalek@netbeans.org>
Log: Code completion modified to show a list of templates that apply to the current editor file (see issue #167108).


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo