Bug 167098 - Ignore VCS generated file events during large VCS operations
Ignore VCS generated file events during large VCS operations
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Vitezslav Stejskal
issues@editor
: API, PERFORMANCE
: 167671 175631 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-15 12:41 UTC by Vitezslav Stejskal
Modified: 2009-10-29 16:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Prototype of versioning-indexing integration (44.75 KB, text/plain)
2009-09-17 20:55 UTC, Vitezslav Stejskal
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vitezslav Stejskal 2009-06-15 12:41:01 UTC
When VCS does a large scale operation that can potentially affect many files (eg. an update from the remote repository)
the indexing infrastructure should not react to every single file event fired from the VCS operation. Instead it should
mark the affected roots dirty and rescan them when the VCS operation is finished.
Comment 1 Vitezslav Stejskal 2009-06-15 12:43:51 UTC
I'm not sure where/how exactly this should be implemented, but I filed it here, because I intend to do some work in this
are in 6.8 timeframe.
Comment 2 Vitezslav Stejskal 2009-09-11 08:48:31 UTC
*** Issue 167671 has been marked as a duplicate of this issue. ***
Comment 3 Vitezslav Stejskal 2009-09-11 08:49:29 UTC
It's got a P2 duplicate, so I'm making it P2 as well.
Comment 4 Vitezslav Stejskal 2009-09-17 20:55:24 UTC
Created attachment 87885 [details]
Prototype of versioning-indexing integration
Comment 5 Vitezslav Stejskal 2009-09-17 21:05:34 UTC
Tomas, could you please have a look at the attached patch and give me some feedback? It contains new
versioning.indexingbridge module, which implements the bridge between versioning.util and parsing.api modules. There is
also new IndexingBridge class in versioning.util's API, which is then used from subversion module to refresh filesystems
and rescan changes. I'm primarily interested in knowing whether the API in IndexingBridge is adequate for the needs of
our VCS plugins. It seems to be ok for subversion, but I haven't looked at other plugins and obviously I might even have
overlooked something in the subversion module itself. Thanks

Once we are confident that the API is suitable for all our existing VCS plugins, I'll take it for API review.
Comment 6 Vitezslav Stejskal 2009-10-15 09:52:49 UTC
http://hg.netbeans.org/jet-main/rev/1e1851fcf4a1
Comment 7 Jan Lahoda 2009-10-29 16:43:11 UTC
*** Issue 175631 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo