Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 167058 - Configuration management is broken
Configuration management is broken
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Thomas Preisler
issues@cnd
67patch1-verified
:
: 168583 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-14 11:21 UTC by Leonid Lenyashin
Modified: 2009-07-17 13:17 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Leonid Lenyashin 2009-06-14 11:21:26 UTC
Way to reproduce:
- Go to project properties and click on Manage Configurations
- Duplicate "Debug" config and rename it to "Test"
- Set "Test" as Active config (at this point everything is correctly displayed in ConfManagement dialog)
- Press "Ok" and get back to the editor
Surprisingly in the drop down list of configurations at "Run" toolbar you will still see "Debug". Click on the drop down
list and there is no "Test" on the list. Click on "Manage Configurations" and you will see that "Test" is still here,
but the active config is Debug.
Alexander, please, evaluate for showstopper status. I'm not sure it is a showstopper, but by this moment I haven't found
any workaround.
Comment 1 Leonid Lenyashin 2009-06-14 11:28:21 UTC
I've found a workaround: once you change configuration using dropdown list it is updated and "Test" appears in the list,
so as second action one can pick it.
Comment 2 Alexander Pepin 2009-06-15 10:46:04 UTC
I see two issues here.
 The first one is that only the configuration from the top of the list in manage configurations dialog can be set as
active so if user selects e.g. Release and tries to set it active it will not happen until the user moves Release on the
top of the list of available configurations.
 The second one is that a new configuration appears in the drop down list of configurations at "Run" toolbar only after
restarting IDE.

IMO it's not a showstopper for 6.7 but it should be definitely fixed in 6.7 patch1.
Comment 3 Thomas Preisler 2009-06-15 22:17:50 UTC
Problem confirmed and also confirmed that it did work correctly in 6.5.1
Comment 4 Thomas Preisler 2009-06-16 04:07:30 UTC
Fixed missing notofication. Also fixed problem with setting active conf in Configuration Management dialog.
Comment 5 Quality Engineering 2009-06-16 19:13:01 UTC
Integrated into 'main-golden', will be available in build *200906161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4093526221c2
User: Thomas Preisler <thp@netbeans.org>
Log: #167058 Configuration management is broken
Comment 6 Alexander Pepin 2009-06-17 15:31:37 UTC
verified in trunk 20090617 build and dev build for release 67.
It should be a candidate for 6.7 patch1.
Comment 7 pgebauer 2009-07-01 09:45:04 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/6aa8421256fc
Comment 8 Alexander Pepin 2009-07-15 16:58:18 UTC
verified in nb6.7.1rc
Comment 9 Alexander Pepin 2009-07-17 13:17:32 UTC
*** Issue 168583 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo