Bug 166997 - LayerUtils.getEffectiveSFS still blocks UI for couple seconds 1st time it is called
LayerUtils.getEffectiveSFS still blocks UI for couple seconds 1st time it is ...
Status: RESOLVED DUPLICATE of bug 169841
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jesse Glick
issues@apisupport
:
: 167383 167594 169396 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 15:52 UTC by rmichalsky
Modified: 2010-02-04 14:07 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Profiler snapshot (9.95 KB, application/octet-stream)
2009-06-29 14:47 UTC, another_bad_hair_day
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rmichalsky 2009-06-12 15:52:12 UTC
More prominent with current "slowness detected" feature, retrieving localized names is done in UI and can be slow. Needs
to be offloaded to background thread.
Comment 1 rmichalsky 2009-06-19 18:07:05 UTC
*** Issue 167383 has been marked as a duplicate of this issue. ***
Comment 2 rmichalsky 2009-06-24 14:55:57 UTC
Forgot to mention, most visible place for this is New Action Wizard.
Comment 3 rmichalsky 2009-06-24 14:56:17 UTC
*** Issue 167594 has been marked as a duplicate of this issue. ***
Comment 4 another_bad_hair_day 2009-06-24 15:03:36 UTC
FYI, UI is blocked on each New Action call and not just the first time as the title might suggest.
Comment 5 another_bad_hair_day 2009-06-29 14:47:11 UTC
Created attachment 84136 [details]
Profiler snapshot
Comment 6 another_bad_hair_day 2009-06-29 15:42:00 UTC
Actually, after some investigation, my problem was just that too many jar files were found ...
moving the 684 jar belonging to **/locale folders outside Netbeans just solved my problem.
Comment 7 rmichalsky 2009-08-19 09:24:36 UTC
*** Issue 169396 has been marked as a duplicate of this issue. ***
Comment 8 Jesse Glick 2010-02-04 14:07:29 UTC

*** This bug has been marked as a duplicate of bug 169841 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo