Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166959 - Java.lang.illegalargumentexception
Java.lang.illegalargumentexception
Status: RESOLVED DUPLICATE of bug 127252
Product: obsolete
Classification: Unclassified
Component: Registration
5.x
All Windows Vista
: P3 (vote)
: TBD
Assigned To: dlipin
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-12 03:27 UTC by rekha_vedi
Modified: 2009-07-02 13:00 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description rekha_vedi 2009-06-12 03:27:12 UTC
org.xml.sax.SAXParseException: Premature end of file.
	at com.sun.org.apache.xerces.internal.parsers.DOMParser.parse(DOMParser.java:239)
	at com.sun.org.apache.xerces.internal.jaxp.DocumentBuilderImpl.parse(DocumentBuilderImpl.java:283)
	at org.netbeans.modules.reglib.StatusDocument.initializeDocument(StatusDocument.java:183)
Caused: java.lang.IllegalArgumentException: Error generated in parsing
	at org.netbeans.modules.reglib.StatusDocument.initializeDocument(StatusDocument.java:187)
	at org.netbeans.modules.reglib.StatusDocument.load(StatusDocument.java:97)
	at org.netbeans.modules.reglib.StatusData.loadFromXML(StatusData.java:121)
	at org.netbeans.modules.registration.NbConnection.checkStatus(NbConnection.java:129)
	at org.netbeans.modules.registration.NbConnection.access$000(NbConnection.java:91)
	at org.netbeans.modules.registration.NbConnection$1$1.run(NbConnection.java:110)
	at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
[catch] at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:997)


Hi 

Please refer the above error details and kindly help me to get rid out from this problem.
My Operating system is Windows vista (japanese version). Whenever i am starting the netbeans in cmd prompt with the
following option 

start netbeans.exe --locale en=us

The above exception occurs. I reffered same post which has posted earlier by someone but its not working for me and
insufficent to fix the error. Thanks in Advance

Regards
Rekha.V
Comment 1 Alexey Butenko 2009-06-12 06:39:33 UTC
Defenitely not p1 and not related to properties
Comment 2 Alexei Mokeev 2009-06-12 07:00:47 UTC
According to stack trace it may come from reglib -> ide/registration for evaluation.
Comment 3 mslama 2009-06-18 15:25:47 UTC
Missing version info. Please add NB version you use. The best is to add beginning of IDE log.
Comment 4 mslama 2009-06-18 15:37:12 UTC
It looks like xml config file is present but is empty. Workaround is to delete folder
$HOME/.netbeans-registration/<NB_VERSION NUMBER> eg.: $HOME/.netbeans-registration/6.5.

In Dec 2008 I added handling of empty registration.xml file. But in this case it looks like empty
$HOME/.netbeans-registration/6.7/status.xml so please first check this file if it is empty and if not what is its content.

Comment 5 dlipin 2009-07-02 13:00:50 UTC
Looks like the Issue 127252
http://www.netbeans.org/issues/show_bug.cgi?id=127252
http://statistics.netbeans.org/analytics/detail.do?id=25614

rekha_vedi, feel free to reopen if you encounter this issue in 6.7.

*** This issue has been marked as a duplicate of 127252 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo