Bug 166941 - [67cat] [perf-profileme] System generates slow issues during code completion for rails projects
[67cat] [perf-profileme] System generates slow issues during code completion ...
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
PC Linux
: P3 (vote)
: 7.0
Assigned To: Dusan Balek
issues@editor
perf-profileme
: PERFORMANCE
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-11 20:54 UTC by esmithbss
Modified: 2010-11-12 09:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Profile Trace (8.23 KB, application/octet-stream)
2009-06-11 20:55 UTC, esmithbss
Details
Profile Trace (8.27 KB, application/octet-stream)
2009-06-11 20:56 UTC, esmithbss
Details
Profile Trace (8.09 KB, application/octet-stream)
2009-06-11 20:56 UTC, esmithbss
Details
Profile Trace (9.25 KB, application/octet-stream)
2009-06-12 07:35 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2009-06-11 20:54:55 UTC
[ BUILD # : 200906081401 ]
[ JDK VERSION : 1.6.* ]

While initializing the code-completion dialogs and lists under Ruby
On Rails, the system generated slowness profiles.
Comment 1 esmithbss 2009-06-11 20:55:28 UTC
Created attachment 83458 [details]
Profile Trace
Comment 2 esmithbss 2009-06-11 20:56:02 UTC
Created attachment 83459 [details]
Profile Trace
Comment 3 esmithbss 2009-06-11 20:56:35 UTC
Created attachment 83460 [details]
Profile Trace
Comment 4 esmithbss 2009-06-12 07:35:45 UTC
Created attachment 83484 [details]
Profile Trace
Comment 5 Erno Mononen 2009-08-24 12:38:04 UTC
I couldn't see anything ruby specific in the snapshots, it seems that PatchedHtmlRenderer#renderHtml that gets invoked 
multiple times by GsfCompletionItem is taking a rather long time. Passing to editor for further investigation.
Comment 6 Vitezslav Stejskal 2009-08-24 16:02:23 UTC
200906081401-slow-creating-code-completion-for-ror.nps is somewhat different than the other three snapshots. It shows an
activity in rubyforge ReadersSupport. So, I'll ignore it. The other three show activity in PatchedHtmlRenderer and its
use of FontMetrics.getStringBounds. I'm not sure how this can be made faster though. What OS are you running? Is there
anything special about your fonts, look & feel, etc?
Comment 7 esmithbss 2009-08-24 16:11:34 UTC
Ubuntu 9.04
Gateway m460 notebook
2gb memory
Gnome 2.x
Gtk LAF

Also happens on a Dell Inspiron 600 with dual core and 4gb mem running WinXP.
Comment 8 Erno Mononen 2009-08-24 16:24:27 UTC
Wrt. ReadersSupport - that's the ruby debugger loop, so it can indeed be ignored here.
Comment 9 Dusan Balek 2009-10-09 15:18:19 UTC
Strange. Does it happen under Ruby On Rails only, or is it reproducible also in the Java editor?
Comment 10 Dusan Balek 2010-11-12 09:45:17 UTC
Most of the time spent in the FontMetrics.getStringBounds. Since there are no other similar reports since NB 6.7, closing as WONTFIX for now.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo