Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166868 - com.sun.jdi.VMDisconnectedException at com.sun.tools.jdi.TargetVM.waitForReply
com.sun.jdi.VMDisconnectedException at com.sun.tools.jdi.TargetVM.waitForReply
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Java
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
http://statistics.netbeans.org/except...
67patch1-verified, EXCEPTIONS_REPORT
:
: 168176 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-10 16:54 UTC by dlipin
Modified: 2009-10-22 15:43 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dlipin 2009-06-10 16:54:44 UTC
Build: NetBeans IDE 6.7 RC3 (Build 200906100001)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86
User comments: Terminated Java process which the debugger was attached to using Task Manager.
STACKTRACE: (first 10 lines)
com.sun.jdi.VMDisconnectedException
        at com.sun.tools.jdi.TargetVM.waitForReply(TargetVM.java:285)
        at com.sun.tools.jdi.VirtualMachineImpl.waitForTargetReply(VirtualMachineImpl.java:1015)
        at com.sun.tools.jdi.PacketStream.waitForReply(PacketStream.java:51)
        at com.sun.tools.jdi.JDWP$ObjectReference$EnableCollection.waitForReply(JDWP.java:4712)
        at com.sun.tools.jdi.JDWP$ObjectReference$EnableCollection.process(JDWP.java:4693)
        at com.sun.tools.jdi.ObjectReferenceImpl.enableCollection(ObjectReferenceImpl.java:416)
        at org.netbeans.modules.debugger.jpda.expr.EvaluationContext.enableCollectionOfObjects
(EvaluationContext.java:310)
        at org.netbeans.modules.debugger.jpda.expr.EvaluationContext$1.propertyChange(EvaluationContext.java:286)
        at java.beans.PropertyChangeSupport.firePropertyChange(PropertyChangeSupport.java:339)
        at org.netbeans.modules.debugger.jpda.JPDADebuggerImpl.firePropertyChange(JPDADebuggerImpl.java:1837)
Comment 1 Martin Entlicher 2009-06-11 16:29:27 UTC
Fixed in changeset:   134789:9e622275805b
http://hg.netbeans.org/main/rev/9e622275805b
Comment 2 Quality Engineering 2009-06-15 08:57:47 UTC
Integrated into 'main-golden', will be available in build *200906150201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9e622275805b
User: mentlicher@netbeans.org
Log: #166868 - Catch exceptions thrown from ObjectReference.enableCollection().
Comment 3 Martin Entlicher 2009-07-07 10:20:24 UTC
Adding as a patch candidate, trivial and safe fix, lot of reports.
Comment 4 Martin Entlicher 2009-07-07 10:21:05 UTC
*** Issue 168176 has been marked as a duplicate of this issue. ***
Comment 5 Marian Mirilovic 2009-07-08 08:27:57 UTC
verified
Comment 6 pgebauer 2009-07-08 16:37:56 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/c96c0f81cd60


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo