Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166818 - Gizmo options don't work before the first Project Run
Gizmo options don't work before the first Project Run
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Profile
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Maria Tishkova
issues@cnd
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-09 23:07 UTC by Thomas Preisler
Modified: 2009-07-16 12:02 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2009-06-09 23:07:42 UTC
Changing Gizmo options doesn't seem to have any effect anymore. The options are no longer store in project/nbproject/private/configurations.xml and 
changing them don't seem to have any effect. One consequence is profiling cannot be turned off!
Comment 1 Alexander Pepin 2009-06-10 16:35:51 UTC
Do you mean they don't work in trunk?
Comment 2 Maria Tishkova 2009-06-11 07:57:49 UTC
Thomas, please be more specific, for me it works in both trunk and release67 branch.
Which version do you use? On which platform?
Comment 3 Thomas Preisler 2009-06-15 17:58:37 UTC
False alarm: I did a full clean and a complete build and everything seems to work just fine. Will close again....
Comment 4 Thomas Preisler 2009-06-15 17:59:02 UTC
working....
Comment 5 Thomas Preisler 2009-06-16 20:31:06 UTC
The problem is still there:

Open project properties
Click on Profile
Uncheck any of the Indicators
Click OK

Open the properties again and the unchecked iIndicators are now checked again
Close/open project and Indicators are still checked.

Problem: state of the three checkboxes are not saved.
Comment 6 Maria Tishkova 2009-06-17 09:23:35 UTC
Thomas, 

1) please attach log to understand the version of NB
2) cat nbproject/configuration.xml
3) cat nbproject/private/configuration.xml

I didn't change the code which saves the changes ...
Comment 7 Maria Tishkova 2009-06-17 11:54:10 UTC
The more detailed description is the following: "Gizmo options don't work before the first Project Run"
As it works right after the very first Run


Comment 8 Maria Tishkova 2009-06-17 12:00:24 UTC
I think it is a P3 but should be mentioned in Release Nots
Comment 9 Maria Tishkova 2009-06-17 17:38:20 UTC
fixed in http://hg.netbeans.org/cnd-main/rev/ea526521cbe3
Comment 10 Thomas Preisler 2009-06-17 21:06:12 UTC
The fix fix is not entirely correct. It is better not to store the value of a property if it is the default value. If
there in the future are changes in what the default indicators are, then it won't work with older projects because it
now stores all property values. Look at the other properties. Only properties different from default values are stored.
Comment 11 Quality Engineering 2009-06-18 06:58:39 UTC
Integrated into 'main-golden', will be available in build *200906180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/ea526521cbe3
User: Maria Tishkova <mromashova@netbeans.org>
Log: fixed IZ#166818 Gizmo options don't work before the first Project Run
Comment 12 Maria Tishkova 2009-06-18 12:42:51 UTC
Thomas, I have fixed the issue you have pointed me out.
Please review the fix, if you think it is still incorrect I need your advise as 
 I do not understand well how MakeConfiguration and Project Properties work.

See rev http://hg.netbeans.org/cnd-main/rev/5f260c514b1a
Comment 13 Quality Engineering 2009-06-19 07:46:52 UTC
Integrated into 'main-golden', will be available in build *200906190201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/5f260c514b1a
User: Maria Tishkova <mromashova@netbeans.org>
Log: add fix IZ#166818 Gizmo options don't work before the first Project Run
store onlt values for the tools with the values different from the default
Comment 14 soldatov 2009-06-29 15:28:17 UTC
Fix should be added into patch1 also, because some programs work slowly under profiler with default options.

Platform: OpenSolaris 2009.06 (Solaris 10 also)
Data Provider: Sun Studio 12 update 1 (Sun Studio 12 also)
Scenario:
- Create Freeway project
- Run project
==> Project is started for ~1 minute
- Switch off Memory and Thread indicators
- Run project
==> Project is started for 1 second
- Restart IDE
==> Project is started for ~1 minute (Memory and Thread indicators are switched on)
Comment 15 Maria Tishkova 2009-06-30 17:27:38 UTC
close it as fixed again  as from what I understand it should be in FIXED state to be migrated to 67patch1
Comment 16 soldatov 2009-07-01 11:25:02 UTC
Verified in trunk (Build 200907010200)
Comment 17 pgebauer 2009-07-01 14:24:35 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/f6372f176973
Comment 18 dnikitin 2009-07-15 17:20:35 UTC
verified in  IDE 6.7.1 RC (Build 200907150227)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo