Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166801 - [69cat] [67cat] order of items in debuggers source window not adjustable
[69cat] [67cat] order of items in debuggers source window not adjustable
Status: VERIFIED FIXED
Product: debugger
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P2 with 1 vote (vote)
: 6.x
Assigned To: Martin Entlicher
issues@debugger
: UI
Depends on:
Blocks: 174773 174774 178077
  Show dependency treegraph
 
Reported: 2009-06-09 17:29 UTC by ulfzibis
Modified: 2010-03-30 15:23 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2009-06-09 17:29:47 UTC
[ BUILD # : RC1 ]
[ JDK VERSION : 1.6.* ]

In trying to workaround Issue 165742 I have experienced, that I can't
adjust order of additionally added sources to debuggers source
window, so often I can't prevent from running in wrong source files,
if I have overwritten then.
Comment 1 Martin Entlicher 2009-06-10 16:58:37 UTC
Issue #165742 should be fixed in the first place. Then the sources should have correct order.
The order can not be changed intentionally, because the correct order should always be retrieved from the class path.
However, I agree that for manually added source roots you should be able to adjust the order. 
Comment 2 ulfzibis 2009-10-05 15:18:25 UTC
Suggestion:
1. Order of source roots retrieved from the classpath should stick in correct order.
2. Manually added source roots should have different color/text style in Sources window.
3. Manually added source roots should be movable freely, even inside and before the fixed classpath block.
Comment 3 Martin Entlicher 2009-10-09 09:48:47 UTC
Making this as P2, since this is essential for projects defining -Xbootclasspath. See issue #165742.

It looks like we need to be able to change even the order of source roots retrieved from the classpath. Then, it would
be enough to move the source root corresponding to boot class-path before the JDK src.

My plan to solve this is to add contextual actions "Move Up" and "Move Down" everywhere (maybe we could also try to
implement drag-and-drop, which Outline view should support now) and a contextial action "Reset Order", which change the
order beck to the original (according to the known execution class path).
Comment 4 ulfzibis 2009-10-09 10:12:07 UTC
Martin, I like this idea very much, as user get's the power to easily hack a JDK class, to include in his project or
just for research purpose, without having to set up a freeform project. +1

I suggest, to save these settings project-dependent, best in project.properties.
There may be a little regression, as additional sources to the debugger currently are saved globally in the IDE.
Maybe not only folders, jars, libs, but also single java files should be addable and order-adjustable.
Comment 5 Martin Entlicher 2009-10-09 10:47:06 UTC
Currently the settings (additional sources and now also the order) are saved project-base, but into NB-user-dir.
This should probably change in the future (I do not want to make such change now in the stabilization period) also for
breakpoints and watches. I agree that it might have more sense to save them into the project space (private.properties).

> also single java files should be addable and order-adjustable
I do not see much use for this - class-path is composed from source-roots and you can not have identical classes under
one source-root. It would clutter the UI too much.
Comment 6 ulfzibis 2009-10-09 11:42:41 UTC
I think, only debugger source setting should go into project.properties to have it shareable between developers, but
watches and breakpoints better go into private.properties.

The problem while saving in NB-user-dir is, those setting are not shareable between developers, can't be versioned in
repository and additionally sharing them by the export/import tool is ridiculous, as those settings can't be selected
project-based.
Comment 7 Martin Entlicher 2009-10-14 18:43:24 UTC
Fixed in changeset:   149165:4ebb16309809 and changeset:   149168:72b80373e732
http://hg.netbeans.org/main/rev/4ebb16309809
http://hg.netbeans.org/main/rev/72b80373e732

DnD is not implemented yet, it depends on issue #174569.
Comment 8 Martin Entlicher 2009-10-14 18:46:27 UTC
I've added "Move Up", "Move Down" and "Reset Order" actions to popup menu into Sources window. This allows to freely
manage order of debugger source roots. Sources are picked in the defined order when debugger is stopped in a class.
Comment 9 Quality Engineering 2009-10-15 10:23:22 UTC
Integrated into 'main-golden', will be available in build *200910150201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4ebb16309809
User: mentlicher@netbeans.org
Log: #166801 - Be able to change the order of source roots.
Comment 10 ulfzibis 2009-10-16 19:13:02 UTC
Works fine. :-)
I've added some enhancements:
Issue 174773, Issue 174774.

Maybe a problem will come up that it is allowed to change the order defined _inside_ Source Package Folder.
Comment 11 ulfzibis 2010-03-25 11:32:20 UTC
This fix was removed from bug 178077.
Can't use 6.9 for JDK development.
Comment 12 Martin Entlicher 2010-03-30 12:18:25 UTC
Changing back to fixed. This was not removed, Move Up/Down actions are still there.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo