Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166713 - Statements right after heredocs highlighted as errors
Statements right after heredocs highlighted as errors
Status: VERIFIED FIXED
Product: ruby
Classification: Unclassified
Component: Editing
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Erno Mononen
issues@ruby
67patch1-verified
:
: 166956 167060 168006 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-08 12:06 UTC by Erno Mononen
Modified: 2009-07-15 12:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Erno Mononen 2009-06-08 12:06:34 UTC
The parser appears to have issues with the following:

hdoc = <<END
END
puts hdoc

The last line in the above gets incorrectly highlighted as an error (unexpexted tIDENTIFIER); adding a line break 
before it makes the error go away. Needs to be fixed in jruby-parser.
Comment 1 Erno Mononen 2009-06-11 13:15:35 UTC
I'm working on a fix for jruby-parser to fix this. Rather annoying when editing/viewing source that has a lot of 
heredocs. Will try to provide a fix in time for patch1.
Comment 2 Erno Mononen 2009-06-11 14:15:42 UTC
Fixed in jruby-parser and updated the lib in 280f35150229.
Comment 3 Erno Mononen 2009-06-11 15:52:54 UTC
Martine, can you please verify this? I'd like to get this fix to patch1.
Comment 4 Erno Mononen 2009-06-12 06:31:52 UTC
*** Issue 166956 has been marked as a duplicate of this issue. ***
Comment 5 Quality Engineering 2009-06-12 09:20:34 UTC
Integrated into 'main-golden', will be available in build *200906120201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/280f35150229
User: Erno Mononen <emononen@netbeans.org>
Log: #166713: Statements right after heredocs highlighted as errors
Comment 6 Martin Schovanek 2009-06-12 14:37:40 UTC
Verified in trunk build.
Comment 7 Erno Mononen 2009-06-12 15:43:42 UTC
Thanks for verifying, I'm nominating this for 67patch1. 
Comment 8 Erno Mononen 2009-06-15 08:33:36 UTC
*** Issue 167060 has been marked as a duplicate of this issue. ***
Comment 9 pgebauer 2009-07-01 11:01:37 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/1bac295d7121
Comment 10 Erno Mononen 2009-07-02 07:25:42 UTC
*** Issue 168006 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo