Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166591 - IDE freezes for a few second when trying to do SVN/HG commit
IDE freezes for a few second when trying to do SVN/HG commit
Status: VERIFIED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Issuetracking Framework
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Marian Petras
issues@connecteddeveloper
67patch1-verified
: PERFORMANCE
: 167271 167323 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-05 10:43 UTC by Petr Dvorak
Modified: 2009-07-27 09:20 UTC (History)
5 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump (22.13 KB, text/plain)
2009-06-05 10:43 UTC, Petr Dvorak
Details
patch for repository clone "release67_fixes" (22.75 KB, patch)
2009-07-09 14:01 UTC, Marian Petras
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Dvorak 2009-06-05 10:43:08 UTC
Product Version: NetBeans IDE Dev (Build 200906041401)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Linux version 2.6.22-p4smp running on i386; UTF-8; cs_CZ (nb)

1. Log in to Kenai.com from NB IDE
2. Checkout some project (svn)
3. Do some changes + commit
-> IDE freezes for a while, UI does not repaint
-> ThreadDump shows an activity in bugtracking modules
Comment 1 Petr Dvorak 2009-06-05 10:43:32 UTC
Created attachment 83227 [details]
Thread Dump
Comment 2 Marian Petras 2009-06-15 16:12:10 UTC
SvnHookImpl.getKnownRepositories() should not be called from the AWT thread.
Comment 3 Marian Petras 2009-06-16 13:56:27 UTC
Fixed.

List of known repositories (to be displayed in the commit dialogue when updating an issue) is now populated in a non-AWT
thread.

Changeset:
08c55bf8deb1
Comment 4 Quality Engineering 2009-06-17 08:32:58 UTC
Integrated into 'main-golden', will be available in build *200906170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/08c55bf8deb1
User: Marian Petras <mpetras@netbeans.org>
Log: fixed bug #166591 - "IDE freezes for a few second when trying to do SVN commit"
Comment 5 Petr Dvorak 2009-06-18 08:46:19 UTC
*** Issue 167271 has been marked as a duplicate of this issue. ***
Comment 6 Marian Mirilovic 2009-06-18 20:38:20 UTC
*** Issue 167323 has been marked as a duplicate of this issue. ***
Comment 7 _ rkubacki 2009-06-19 04:28:15 UTC
In bug #167271 I did hg commit that affect only my local repository so I do not see why it was talking to bug tracking
database.
Comment 8 Marian Mirilovic 2009-06-19 07:34:32 UTC
> In bug #167271 I did hg commit that affect only my local repository so I do not see why it was talking to bug tracking
database.

so did I in Issue 167323
Comment 9 Petr Dvorak 2009-07-02 13:15:34 UTC
Cannot reproduce in

Product Version: NetBeans IDE Dev (Build 200907020200)
Java: 1.6.0_13; Java HotSpot(TM) Client VM 11.3-b02
System: Linux version 2.6.28-11-generic running on i386; UTF-8; en_US (nb)

Verified
Comment 10 pgebauer 2009-07-07 10:01:16 UTC
Above mentioned changeset depends on changes those have been done in the trunk after the NetBeans 6.7 release.
Could you please provide a changeset which can be applicable on the release67_fixes branch?

Comment 11 Marian Petras 2009-07-09 14:01:08 UTC
Created attachment 84543 [details]
patch for repository clone "release67_fixes"
Comment 12 Marian Petras 2009-07-09 14:04:50 UTC
The attached patch enhances changes made in changeset #08c55bf8deb1, which in fact was a partial fix of essentially the
same problem (reported as bug #165694). Later I found another minor bug in the patches, which I also fixed (changeset
#700f4edbb5e0, trivial).

I merged the three changesets (08c55bf8deb1, 08c55bf8deb1 and 700f4edbb5e0), thus making a single proper changeset that
fixes both bugs:

   bug #165694: socket communication should not block AWT
   bug #166591: IDE freezes for a few second when trying to do SVN/HG commit

Because application of the attached patch fixes also bug #165694, you should probably also mark that bug as
67patch1-candidate.
Comment 13 Petr Blaha 2009-07-09 16:31:16 UTC
SW 67patch1-fixed is used when fix is in release67_fixes clone.
Comment 14 pgebauer 2009-07-09 23:11:10 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/f2e027b51427
Comment 15 pribyl 2009-07-16 16:12:20 UTC
Product Version: NetBeans IDE 6.7.1 RC (Build 200907150227)
Java: 1.6.0_14; Java HotSpot(TM) Client VM 14.0-b16
System: Windows XP version 5.1 running on x86; Cp1250; cs_CZ (nb)

Verified in 6.7.1 RC

(I followed Peter's steps, the IDE worked normally. During and after the commit it was responsive.)  
Comment 16 Petr Dvorak 2009-07-16 16:36:47 UTC
Yes, I didn't change the status whiteboard... thanks Pavel...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo