Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166554 - [67cat] Only 21 INSERTED should have been thousands.
[67cat] Only 21 INSERTED should have been thousands.
Status: RESOLVED DUPLICATE of bug 157022
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 14:11 UTC by nleck
Modified: 2009-06-16 14:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description nleck 2009-06-04 14:11:58 UTC
I ran the SQL 

INSERT INTO xxxx SELECT * FROM yyy

There was no error everything looked good. Later when I ran the program I found that only 21 rows where inserted out of
the expected thousands. 

I suspect that you have set the max rows on the connection. This is very very dangerous. Maybe your looking for the word
SELECT.
Comment 1 Jiri Kovalsky 2009-06-09 15:46:21 UTC
Jirko, can you please take a look at this? Sounds bad...
Comment 2 Jiri Rechtacek 2009-06-10 05:44:31 UTC
I'm going to investigate it soon....
Comment 3 Petr Blaha 2009-06-10 10:48:46 UTC
Which database do you use? I guess the duplicate of the issue #157022.
Comment 4 nleck 2009-06-10 11:27:47 UTC
This was Sybase. 
Comment 5 nleck 2009-06-10 11:32:21 UTC
Yes it looks like a duplicate of #157022.

It's a scary one... I got my self into a complete mess moving records around with SELECT INTO and DELETE. There was no
indication that only partial records were being effected. 

If this isn't fixed you should at least highlight the issue.
Comment 6 Petr Blaha 2009-06-10 12:11:38 UTC
I agree that the issue is serious and we should fix it. Which database/driver do you use? I was not able to reproduce it
on MySQL neither javadb. It seems that bug is related to MS SQL server only. 
Comment 7 nleck 2009-06-10 12:16:48 UTC
This is Sybase not MS SQL. 

I use jtds-1.2.2.jar 

The native Sybase jConnect driver has other problems with NB. 
Comment 8 Jiri Rechtacek 2009-06-16 14:17:58 UTC

*** This issue has been marked as a duplicate of 157022 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo