Bug 166541 - The 'My Issues' query in Kenai window disappears when user logs out
The 'My Issues' query in Kenai window disappears when user logs out
Status: RESOLVED FIXED
Product: connecteddeveloper
Classification: Unclassified
Component: Team Framework
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jan Becicka
issues@connecteddeveloper
: PLAN
Depends on:
Blocks: 165924
  Show dependency treegraph
 
Reported: 2009-06-04 12:33 UTC by Ondrej Langr
Modified: 2009-08-13 17:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Kenai window appearance when a user is logged-off. (72.53 KB, image/png)
2009-06-04 12:34 UTC, Ondrej Langr
Details
minor change, please use this (72.63 KB, image/png)
2009-08-10 15:09 UTC, Ondrej Langr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ondrej Langr 2009-06-04 12:33:15 UTC
This was originally "as designed", but since we decided to keep user-created queries there even if users are logged out
which changes the situation somewhat - other per-user queries are kept even after logout.

Also, during usability study, we've found out that users who did not check the 'remember me' checkbox in the login
dialog were confused by the fact that 'My Issues' query disappeared after IDE restart.

As a result, a suggestion is to keep the 'My Issues' item in the Kenai window whenever user-created queries are present.
Since at that point, we may not know what the actual query is (it is server-side stored) we need to display it without
bug counts, right. Attached is a visual representation with unavailable 'My Issues' counts. 

In short, either both user-created queries and my issues node will be present, or none (before first log-in).

Tomas, since you've understanding of the underlaying implementation, could you please sanity-check if this makes sense
from the implementation point-of-view?
Comment 1 Ondrej Langr 2009-06-04 12:34:31 UTC
Created attachment 83202 [details]
Kenai window appearance when a user is logged-off.
Comment 2 Tomas Stupka 2009-06-05 00:17:47 UTC
All that bugtracking does and is able to do is to return the display name for a query and a list of its results "1 new",
"2 unseen" and their respective actions. It has no control how the node is rendered in the dashboard - font, color, and
how the to be displayed text is put together - e.g brackets around the display results. We either enhance the api
between bugtracking and dashbord, or the dashboard will take care for th whole thing by itself.
Comment 3 Ondrej Langr 2009-06-09 21:18:23 UTC
Attaching a minor change. Wording and links are different, please use this one. 
Comment 4 Jan Becicka 2009-07-31 10:06:49 UTC
what exactly am I required to do?
Comment 5 Ondrej Langr 2009-08-10 15:09:47 UTC
Created attachment 86046 [details]
minor change, please use this
Comment 6 Tomas Stupka 2009-08-10 16:37:26 UTC
fixed on the bugtracking side

changeset   : 140775:4971cbb95d36
author      : Tomas Stupka <tstupka@netbeans.org>
date        : Mon Aug 10 17:36:47 CEST 2009
Comment 7 Quality Engineering 2009-08-13 06:06:38 UTC
Integrated into 'main-golden', will be available in build *200908130201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/4971cbb95d36
User: Tomas Stupka <tstupka@netbeans.org>
Log: #166541 - The 'My Issues' query in Kenai window disappears when user logs out
Comment 8 Jan Becicka 2009-08-13 07:43:41 UTC
fixed in cdev
Comment 9 Quality Engineering 2009-08-13 17:58:42 UTC
Integrated into 'main-golden', will be available in build *200908131401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/f825cb4f607a
User: Jan Becicka <jbecicka@netbeans.org>
Log: #166541 - The 'My Issues' query in Kenai window disappears when user logs out


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo