Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166535 - IDE updates built-in editor and 'Macro Expansion' tab 4 or more times in second
IDE updates built-in editor and 'Macro Expansion' tab 4 or more times in second
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: TBD
Assigned To: nnnnnk
issues@cnd
67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 11:53 UTC by soldatov
Modified: 2009-07-16 11:11 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2009-06-04 11:53:18 UTC
Scenario:
- Create InputOutput sample
- Open io.c file
- Move mouse's cursor on 'go();' line and press Ctrl-Alt-Click
==> 'Macro Expansion' tab is appeared
- Create Arguments project
==> If mouse's cursor is placed in built-in editor, then for some seconds IDE updates 'Macro Expansion' tab and file in
editor.
Comment 2 Alexey Vladykin 2009-06-04 13:20:08 UTC
I've reviewed the fix. It is safe and correct.
Comment 3 soldatov 2009-06-04 14:20:15 UTC
I can't reproduce this problem. Yes, cursor can jumps 2-3 times. But I don't think it will annoy users, therefore it is
not a P2.
Comment 4 Quality Engineering 2009-06-11 08:38:27 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d4cc02a56109
User: Nick N. Krasilnikov <nnnnnk@netbeans.org>
Log: fixed IZ#166535 : IDE updates built-in editor and Macro Expansion tab 4 or more times in second
Comment 5 soldatov 2009-06-26 11:12:39 UTC
verified in latest (200906251410) build
Comment 6 pgebauer 2009-07-01 09:13:39 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/3e49cacea593
Comment 7 dnikitin 2009-07-15 15:05:47 UTC
verified in IDE 6.7.1 RC (Build 200907150227)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo