Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166529 - Incorrect UI for tests with PHP error
Incorrect UI for tests with PHP error
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: PHPUnit
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
67patch1-verified
:
: 167125 168534 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-04 10:06 UTC by Tomas Mysik
Modified: 2009-07-20 12:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2009-06-04 10:06:40 UTC
To reproduce: have a test with require('some/non-existing/file');

To fix: check the return code from PHPUnit and stop if any error occurs.
Comment 1 Tomas Mysik 2009-06-04 10:12:49 UTC
Hint: remove log files after run; add system property "...keeplogs" for keeping those files to able to evaluate and fix issues
Comment 2 Tomas Mysik 2009-07-03 09:41:19 UTC
Fixed. Filipe, please verify. Thanks a lot.
http://hg.netbeans.org/web-main/rev/53d92601fca8
Comment 3 Tomas Mysik 2009-07-03 14:19:09 UTC
*** Issue 167125 has been marked as a duplicate of this issue. ***
Comment 4 Quality Engineering 2009-07-03 17:37:09 UTC
Integrated into 'main-golden', will be available in build *200907031400* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/53d92601fca8
User: Tomas Mysik <tmysik@netbeans.org>
Log: #166529: Incorrect UI for tests with PHP error
Comment 5 Filip Zamboj 2009-07-07 13:14:44 UTC
Product Version: NetBeans IDE Dev (Build 2009-07-07_12-04-30 )
Java: 1.5.0_17-ea; Java HotSpot(TM) 64-Bit Server VM 1.5.0_17-ea-b01
System: Linux version 2.6.28-13-generic running on amd64; UTF-8; en_US (nb)
Comment 6 pgebauer 2009-07-07 15:49:33 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/f9777a26f9bd
Comment 7 Tomas Mysik 2009-07-14 12:02:47 UTC
*** Issue 168534 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo