Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166332 - IllegalStateException: Some of a set of deleted nodes are not present in the original ones. See #15478; you may need to check that your Children.Keys keys are safely comparable. i: 0 j: 0 This: org.op
IllegalStateException: Some of a set of deleted nodes are not present in the ...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Nodes
6.x
All All
: P3 (vote)
: 6.x
Assigned To: t_h
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
: 166343 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 11:50 UTC by Oleg Khokhlov
Modified: 2009-07-15 12:28 UTC (History)
10 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.29 KB, text/plain)
2009-06-01 11:51 UTC, Oleg Khokhlov
Details
stacktrace (3.29 KB, text/plain)
2009-06-01 14:24 UTC, mjreged
Details
stacktrace (3.30 KB, text/plain)
2009-06-01 15:34 UTC, Michal Mocnak
Details
stacktrace (3.29 KB, text/plain)
2009-06-01 16:18 UTC, martinhavle
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Oleg Khokhlov 2009-06-01 11:50:59 UTC
Build: NetBeans IDE Dev (Build 200905290201)
VM: Java HotSpot(TM) Client VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Windows XP, 5.1, x86

User Comments:
diesil: opening a EA project created by nb 6.5.1

ovk: started ruby IDE and tried to open Servers node in Service tab

javamarshall: Opened Databases Section.



Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy6.childrenAdded(.java:0)
        at org.openide.nodes.Node.fireSubNodesChange(Node.java:1093)
        at org.openide.nodes.EntrySupport$Default.notifyAdd(EntrySupport.java:686)
        at org.openide.nodes.EntrySupport$Default.updateAdd(EntrySupport.java:512)
        at org.openide.nodes.EntrySupport$Default.setEntries(EntrySupport.java:344)
        at org.openide.nodes.Children$Keys$2.run(Children.java:1503)
Comment 1 Oleg Khokhlov 2009-06-01 11:51:05 UTC
Created attachment 83060 [details]
stacktrace
Comment 2 mjreged 2009-06-01 14:24:11 UTC
Build: NetBeans IDE Dev (Build 200905290201)
VM: Java HotSpot(TM) Client VM, 11.2-b01, Java(TM) SE Runtime Environment, 1.6.0_12-b04
OS: Windows XP, 5.1, x86

User Comments: 
Just Expanded Servers Node in Service view

Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy7.childrenAdded(.java:0)
        at org.openide.nodes.Node.fireSubNodesChange(Node.java:1093)
        at org.openide.nodes.EntrySupport$Default.notifyAdd(EntrySupport.java:686)
        at org.openide.nodes.EntrySupport$Default.updateAdd(EntrySupport.java:512)
        at org.openide.nodes.EntrySupport$Default.setEntries(EntrySupport.java:344)
        at org.openide.nodes.Children$Keys$2.run(Children.java:1503)
Comment 3 mjreged 2009-06-01 14:24:20 UTC
Created attachment 83065 [details]
stacktrace
Comment 4 Michal Mocnak 2009-06-01 15:34:08 UTC
Build: NetBeans IDE Dev (Build 200906010201)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.26-2-amd64, amd64

User Comments: 
Open the servers node

Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy6.childrenAdded(.java:0)
        at org.openide.nodes.Node.fireSubNodesChange(Node.java:1093)
        at org.openide.nodes.EntrySupport$Default.notifyAdd(EntrySupport.java:686)
        at org.openide.nodes.EntrySupport$Default.updateAdd(EntrySupport.java:512)
        at org.openide.nodes.EntrySupport$Default.setEntries(EntrySupport.java:344)
        at org.openide.nodes.Children$Keys$2.run(Children.java:1503)
Comment 5 Michal Mocnak 2009-06-01 15:34:17 UTC
Created attachment 83067 [details]
stacktrace
Comment 6 martinhavle 2009-06-01 16:18:14 UTC
Build: NetBeans IDE Dev (Build 200906010201)
VM: Java HotSpot(TM) Client VM, 16.0-b02, Java(TM) SE Runtime Environment, 1.7.0-ea-b57
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy6.childrenAdded(.java:0)
        at org.openide.nodes.Node.fireSubNodesChange(Node.java:1093)
        at org.openide.nodes.EntrySupport$Default.notifyAdd(EntrySupport.java:686)
        at org.openide.nodes.EntrySupport$Default.updateAdd(EntrySupport.java:512)
        at org.openide.nodes.EntrySupport$Default.setEntries(EntrySupport.java:344)
        at org.openide.nodes.Children$Keys$2.run(Children.java:1503)
Comment 7 martinhavle 2009-06-01 16:18:29 UTC
Created attachment 83071 [details]
stacktrace
Comment 8 t_h 2009-06-04 09:47:09 UTC
core-main #9d272134d2ec
Comment 9 t_h 2009-06-04 09:49:40 UTC
*** Issue 166343 has been marked as a duplicate of this issue. ***
Comment 10 Quality Engineering 2009-06-11 08:56:46 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9d272134d2ec
User: Tomas Holy <t_h@netbeans.org>
Log: #166332: ISE: Some of a set of deleted nodes are not present in the original ones.
Comment 11 Petr Blaha 2009-07-03 07:40:29 UTC
Oleg, would you verify the fix in trunk build? Thanks
Comment 12 Oleg Khokhlov 2009-07-03 13:18:08 UTC
v. in ruby IDE 20090703
Comment 13 pgebauer 2009-07-09 15:55:35 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/d48043b11731
Comment 14 Oleg Khokhlov 2009-07-15 12:28:50 UTC
v. in 6.7.1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo