Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166324 - TreeMaker generates extra space
TreeMaker generates extra space
Status: RESOLVED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: fommil
issues@java
: NETFIX
Depends on: 166327
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-01 09:29 UTC by Max Sauer
Modified: 2009-07-20 12:46 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Max Sauer 2009-06-01 09:29:16 UTC
As a result of

http://hg.netbeans.org/main-golden/rev/204b55f53241 (TreeFactory.Break)

TreeMaker generates extra space when passing null argument as label. Ie., instead of

break;

it generates

break[ ];

Note that null is allowed according to javadoc.

Dik.
Comment 1 Rastislav Komara 2009-06-02 07:51:12 UTC
@fommil: This is caused by your fix. The verification goes OK but It looks like there is missing test case. Are you able
to fix this? If not, please inform me ASAP.
Comment 2 fommil 2009-06-02 09:15:52 UTC
@moonko I can look at this, but I can't guarantee any timescales on a fix. When do you need it? I'm not actively working on anything as a priority due to the 
code freeze.
Comment 3 Max Sauer 2009-06-03 13:12:56 UTC
I've added org.netbeans.api.java.source.gen.BreakContinueTest to cover this.
---
http://hg.netbeans.org/jet-main/rev/05c113176b5d
Comment 4 David Strupl 2009-07-20 12:31:46 UTC
Can I make this P3 instead of P2?
Comment 5 fommil 2009-07-20 12:42:07 UTC
Sorry, should have updated here... this was fixed already in issue 166327
Comment 6 fommil 2009-07-20 12:43:08 UTC
patch added as part of 166327
Comment 7 Max Sauer 2009-07-20 12:46:35 UTC
Changing TM as appropriate.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo