Bug 166239 - IllegalArgumentException: Parameter must be a valid folder.
IllegalArgumentException: Parameter must be a valid folder.
Status: CLOSED DUPLICATE of bug 166137
Product: projects
Classification: Unclassified
Component: Generic Projects UI
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milan Kubec
issues@projects
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 09:44 UTC by Marian Mirilovic
Modified: 2009-06-05 10:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.64 KB, text/plain)
2009-05-29 09:44 UTC, Marian Mirilovic
Details
messages.log - contains more exceptions - so probably more helpful (80.22 KB, text/plain)
2009-05-29 09:46 UTC, Marian Mirilovic
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2009-05-29 09:44:01 UTC
Build: NetBeans IDE 6.7 RC1 (Build 200905280001)
VM: Java HotSpot(TM) 64-Bit Server VM, 14.0-b15, Java(TM) SE Runtime Environment, 1.6.0_14-b07
OS: Linux, 2.6.28-11-generic, amd64

User Comments:
mmirilovic: ok, not sure but try to describe ...
- start IDE
- login into kenai.com
- opened one of my projects
- push Collaborate with Kenai on the start page
- Team | Kenai | New project
- put the name / desciption / license ... Next
- chosen external VCS (http://hg.netbeans.org/nb-quality
- chosen Jira 
- push Next (and not sure, but very probable Create new project)
-> exception rises



Stacktrace: 
java.lang.IllegalArgumentException: Parameter must be a valid folder.
        at org.netbeans.spi.project.ui.support.ProjectChooser.setProjectsFolder(ProjectChooser.java:73)
        at org.netbeans.modules.kenai.ui.NewKenaiProjectAction.showLandingPage(NewKenaiProjectAction.java:103)
        at org.netbeans.modules.kenai.ui.NewKenaiProjectAction.actionPerformed(NewKenaiProjectAction.java:75)
        at org.openide.awt.AlwaysEnabledAction.actionPerformed(AlwaysEnabledAction.java:115)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
Comment 1 Marian Mirilovic 2009-05-29 09:44:10 UTC
Created attachment 82964 [details]
stacktrace
Comment 2 Marian Mirilovic 2009-05-29 09:46:26 UTC
Created attachment 82965 [details]
messages.log - contains more exceptions - so probably more helpful
Comment 3 Milan Kubec 2009-06-05 10:14:33 UTC

*** This issue has been marked as a duplicate of 166137 ***
Comment 4 Marian Mirilovic 2009-06-05 10:18:26 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo