Bug 166229 - cannot open IDE Netbeans
cannot open IDE Netbeans
Status: RESOLVED DUPLICATE of bug 160826
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All Windows Vista
: P3 (vote)
: 6.x
Assigned To: issues@versioncontrol
issues@versioncontrol
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-29 02:46 UTC by khawanz
Modified: 2009-05-29 12:09 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (60.36 KB, text/plain)
2009-05-29 02:48 UTC, khawanz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description khawanz 2009-05-29 02:46:27 UTC
while i tried to open IDE, i got the following message in message dialog: 

A java.lang.NoSuchMethodError exception has occurred.
Please report this at http://www.netbeans.org/community/issues.html,
including a copy of your messages.log file as an attachment.
The messages.log file is located in your C:\Users\Hadi\.netbeans\6.5\var\log folder.
Comment 1 khawanz 2009-05-29 02:48:31 UTC
Created attachment 82954 [details]
messages.log
Comment 2 khawanz 2009-05-29 02:56:48 UTC
I already reinstalled it, but this issue still appeared..
Anyone can help me?? Please..
Comment 3 Max Sauer 2009-05-29 08:20:59 UTC
Could you please try running in a fresh userdir? (--userdir commandline switch) or delete $HOME/.netbeans . Also, please try latest trunk builds:

http://bits.netbeans.org/download/trunk/nightly/latest/

Thanks.
Comment 4 Marian Petras 2009-05-29 12:09:16 UTC
This is a duplicate of bug #160826.
It is fixed in development builds of NetBeans 6.5 and also in the latest patch of NetBeans 6.5.

The bug is caused by incompatible changes introduced in Subversion 1.6.x. These changes break functionality of the
Subversion JavaHL library in NetBeans. 

A workaround is to run NetBeans with switch

    -J-DsvnClientAdapterFactory=commandline

Open NB_INSTALL_DIR/etc/netbeans.conf and add the switch to "netbeans_default_options" option. This switch will make
NetBeans use the Subversion command-line client instead of the (incompatible) JavaHL library. Then you can install
NetBeans updates from the Update Centre. One of these updates is for Subversion and causes Subversion to always use the
command-line client, even if the above switch is not used.

*** This issue has been marked as a duplicate of 160826 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo