Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166188 - Deploy on Save deploys too aggressively (when opening a file)
Deploy on Save deploys too aggressively (when opening a file)
Status: VERIFIED DUPLICATE of bug 161367
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Rastislav Komara
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-28 15:15 UTC by Petr Jiricka
Modified: 2009-06-11 12:31 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Jiricka 2009-05-28 15:15:49 UTC
1. Create a new Web application with GF v3 Prelude as the target server
2. Create a class p.NewClass in this application
3. Run the application 
4. Close and reopen the editor tab with p.NewClass

=> Application is redeployed. This is not what I want.
Comment 1 Petr Jiricka 2009-05-28 15:17:40 UTC
I am using this build:

Product Version: NetBeans IDE 6.7 RC1 (Build 200905280001)
Java: 1.6.0_07; Java HotSpot(TM) 64-Bit Server VM 1.6.0_07-b06-57
System: Mac OS X version 10.5.7 running on x86_64; MacRoman; en_US (nb)
Comment 2 Petr Hejl 2009-05-28 15:38:41 UTC
BuildArtifactMapperImpl is firing artifactsUpdated in described situation while it shouldn't.
Comment 3 Dusan Balek 2009-05-28 16:13:38 UTC
The problem is that every file opened in editor is automatically marked as modified by ReposiotryUpdater and it
is immediately reindexed and redeployed (including all its dependent files). The problem is already tracked within issue
#161367.

*** This issue has been marked as a duplicate of 161367 ***
Comment 4 Petr Jiricka 2009-06-02 10:56:37 UTC
Issue 161367 is now fixed, and I confirm that the fix also fixes this issue. Verified with build jet-main #753.
Comment 5 baffyofdaffy 2009-06-11 12:31:39 UTC
*** Issue 152222 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo