Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 166059 - IllegalStateException at java.util.AbstractList$Itr.remove
IllegalStateException at java.util.AbstractList$Itr.remove
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Eclipse project importer
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jesse Glick
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 67patch1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-26 19:23 UTC by levmatta
Modified: 2009-07-21 09:45 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.23 KB, text/plain)
2009-05-26 19:23 UTC, levmatta
Details

Note You need to log in before you can comment on or make changes to this bug.
Description levmatta 2009-05-26 19:23:52 UTC
Build: NetBeans IDE 6.7 Beta (Build 200904242137)
VM: Java HotSpot(TM) 64-Bit Server VM, 11.3-b02, Java(TM) SE Runtime Environment, 1.6.0_13-b03
OS: Linux, 2.6.28-11-generic, amd64

User Comments:
GUEST: importing eclipse project

d_kanov: The exception si thrown on NetBeans 6.1 and NetBeans 6.5 RC1.
This is a showstopper for me and will use eclipse until this is fixed.

GUEST: I was trying to import an Eclipse Project which was working perfectly in Eclipse. When I'm importing , I'm getting this error on Import Failed.

GUEST: import eclipse project

GUEST: Importing projects from an Eclipse workspace



Stacktrace: 
java.lang.IllegalStateException
        at java.util.AbstractList$Itr.remove(AbstractList.java:356)
        at org.netbeans.modules.projectimport.eclipse.j2se.J2SEProjectFactory.addLaunchConfigurations(J2SEProjectFactory.java:224)
        at org.netbeans.modules.projectimport.eclipse.j2se.J2SEProjectFactory.createProject(J2SEProjectFactory.java:137)
        at org.netbeans.modules.projectimport.eclipse.core.Importer.importProjectStage1(Importer.java:233)
        at org.netbeans.modules.projectimport.eclipse.core.Importer.access$600(Importer.java:69)
        at org.netbeans.modules.projectimport.eclipse.core.Importer$3.run(Importer.java:178)
Comment 1 levmatta 2009-05-26 19:23:57 UTC
Created attachment 82820 [details]
stacktrace
Comment 2 Jesse Glick 2009-06-09 20:40:38 UTC
core-main #89615b820738

d_kanov: if this is still a showstopper for you, feel free to increase priority. If you can verify the fix in a 6.8
development build within the next couple of weeks (a comment will be added to this issue when one containing the fix is
available), I can mark this 67patch-candidate.
Comment 3 Quality Engineering 2009-06-11 08:55:30 UTC
Integrated into 'main-golden', will be available in build *200906110201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/89615b820738
User: Jesse Glick <jglick@netbeans.org>
Log: #166059: cannot remove the same list item twice.
Comment 4 Jesse Glick 2009-07-02 16:20:51 UTC
No verification yet, but probably a good backport.
Comment 5 Petr Blaha 2009-07-03 07:46:23 UTC
I tested a little bit in trunk and can't reproduce. Marking as verified.
Comment 6 pgebauer 2009-07-07 16:10:40 UTC
The fix has been ported into the release67_fixes repository.
http://hg.netbeans.org/release67_fixes/rev/abc909da3b5a
Comment 7 Jindrich Sedek 2009-07-21 09:45:49 UTC
v. 67_fixes


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo